Z-Wave graph (without the python)

Using @Buster image as an example here – the tooltip used to be “readable” and somewhere along the long it changed as shown in his screenshot where there’s no line breaks. Anyone have any idea why? Or if it’s fixable?

Would it be possible to add a visual to each box to show ZWave vs ZWave Plus? This would be a big help for those with both type of devices (Yes I am phasing out non plus devices, but the wife only allows so much $$) :slight_smile:

Actually… Bamn I write that then I notice the + sign next to some of the node_id. Perfect that helps :slight_smile:

Just like the python version, how do you go about a massive one? :slight_smile:

A lot of scrolling to the right. Even though i named all rooms too.

Panel seems to load fine, but all my nodes show up as unconnected even hours after being on, using/healing etc. They are all powered mesh devices. Any ideas?

I’m using home assistant via docker if that makes any difference.

Under Configuration -> zwave do the nodes in the dropdown show as complete?

I too noticed the network not updating, think it was 0.91 where it broke? There was a change to not refresh network topology in the background which I suspect is related. Result is everything except the ZWave hub is grey and not connected, but the network is actually working just fine. If you look at a node Node Information in ZWave config, it has no neighbors. Click Refresh Node, then Node Information and now it has neighbors and shows up as linked to the hub in the panel.

My graph shows fine in 0.92.2

Selecting my hub and calling refresh node worked. Thanks! (everything did show as complete before that)

1 Like

I am not sure why. I am running the latest version of chrome and it’s not respecting the br tag. I added

+ “\n” +

To each of the lines under the title property of the entity. In my version of the code that starts on line 450. It produced the correct output of what you and myself were looking for.


Guys, I am not getting a correct picture of my zwave network.
Some devices seem unconnected

@AdamNaj @NigelL Is there a github repo we can follow to track this script? I’ve found individual posts linking to github gists but not sure if it’d be better to follow a repo

I have this bookmarked.

1 Like

Hello, I have downloaded the raw zwavegraph2.html file and put it in my config/panels directory and added the panel_custom lines to my configuration.yaml file but cannot get anything to show up when I click on the Z-wave Graph link in the sidebar of my HASSio instance in Chrome. It works in firefox. Any ideas?

You need to run a network heal or just wait till all zwave devices report.

All the devices have reported. There are just 3 battery devices that are in sleeping mode.

These are aeotec devices. Do I need to change configuration for the reporting?

Came across this thread. Very quick and simple. Took a little while for it to update and get the lines to show up, but worked fine.

I see some people have their graph showing the friendly name. Mine is not. How can I get mine to show them?

Playing around with the panel… new version is now available:

  • you can now pan the graph by dragging it
  • you can now zoom the graph with your mouse wheel
  • the graph initially is scaled to fill the fullscreen width
  • added minimap to visualize which part of the graph you can see at the moment on the screen
  • added 2 more tree layouts (click on the top-legend) - they didn’t necessarily help me make the graph more manageable for me, but may be useful to others in their topology
  • added the ability to show all node connections if someone wants to see the full picture of their Z-Wave mesh
  • fixed the broken new line in the node tooltips
  • you can now click on the node to see the entity dialog

I hope you find this update worthy.


You need to provide a friendly name in Home Assistant… or edit them in the ZW config xml - which is my preferred way.

Hi Adam, where can I get this new version?
Found the link above, https://gist.github.com/AdamNaj/cbf4d792a22f443fe9d354e4dca4de00
Pasted the content into zwavegraph2.html, no new goodies…

1 Like