Z-Wave graph (without the python)


#104

They will appear like that every time you restart Home Assistant and will remain this way to the moment they wake up and report their neighbors. Once they wake up for the first time, they will fall into place.


#105

Thanks for the clarification :+1: works great so far


#106

I just get a blank page. api/panel_custom/zwave request returns 200 but empty response. This is using @AdamNaj latest gist


#107

Which browser are you using? I noticed it doesn’t render on my iPad in the HA app (Safari I assume).

Works on my PC on Firefox.


#108

thank you so much. Its very easy to setup and works great. Nice work!


#109

Any idea why the nodes are overlapping the legend?

image


Big z-wave installation for 130 nodes - worth for Home Assistant?
#110

Added grouping - will be reflected if your zwcfg_0x*.xml file has locations defined for nodes.


#111

Just installed everything this evening. It all looks great and I was able to integrate it pretty easily after digging through this post. The battery visualization is really a neat feature to have. So far no issues, but will report after some usage.

One questions I have in regards to you last post–how is it that one can go about adding the rooms within the z-wave config? Is this something that has to be performed manually?


#112

Ran into some weirdness when I implemented this in my Home Assistant environment.

2018-12-24 08:54:58 ERROR (MainThread) [frontend.js.latest.201812112] http://homeassistant.example.com:8123/api/panel_custom/zwavegraph2:173:15 Uncaught ReferenceError: dagreD3 is not defined

I can see my nodes but there’s no mesh data between them. Is anyone else getting this error?


#113

You need to edit the Open Z-Wave config and for nodes that you want to listed in a group fill-in the location attribute.

<Node id="4" name="Living Room TV Plug" location="Living Room" ...>
...
</Node>

#114

Great, thanks for the confirmation. I did see that currently the z-wave node lists the location as location="". I’ll go through and update and see how that all pans out.


#115

Hi!

What file is it that I need to edit?

The /config/zwcfg_*.xml?
Tried it, but the locations are reset to “” each time i restart Hass, and the grouping is not showing up in the graph.

Could you give me some pointers?
Thanks!


#116

That’s because this file is technically a cache for the Z-Wave state and HA saves it before shutting down.
You need to stop Home Assistant, edit the file and then start it again.


#117

Thanks!

Now got the location to stick, but the grouping is still not showing up however.
screenshot of the OZW settings file

image
I downloaded the latest html version earlier today from gist


#118

Try clearing out the browser cache.


#119

I was getting the same. No connections until I used AdamNaj’s grouped version, Now it works.


#120

I am not entirely sure what I am doing wrong but on chrome it shows " Error while loading this panel." when I go on the tab. I copy pasted the github one into panels and put the other part into my configurations.yaml. It also shows no errors in the log file.


#121

did you copy from the raw format on github?


#122

It was my brower’s cache. I tried everything but after clearing it it just worked. Don’t ask me :slight_smile:


#123

Appears that all of my devices show as unconnected devices even though some are not. Any suggestions?

image