Z-Wave initial config (Hasbian/Razberry on Pi3B+)

Hi from Cyprus. My new installation is driving me nuts. The output from the OZW log is below. This appears to open the serial port…but then the driver fails. I haven’t managed to find out why.
Any ideas please?

2019-09-30 17:18:12.768 Always, OpenZwave Version 1.4.3440 Starting Up
2019-09-30 17:18:22.480 Info, Setting Up Provided Network Key for Secure Communications
2019-09-30 17:18:22.489 Info, mgr,     Added driver for controller /dev/ttyAMA0
2019-09-30 17:18:22.489 Info,   Opening controller /dev/ttyAMA0
2019-09-30 17:18:22.490 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2019-09-30 17:18:22.490 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2019-09-30 17:18:22.492 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2019-09-30 17:18:22.492 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2019-09-30 17:18:22.492 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2019-09-30 17:18:22.492 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2019-09-30 17:18:22.492 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2019-09-30 17:18:22.493 Detail,
2019-09-30 17:18:22.493 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2019-09-30 17:18:22.496 Detail, contrlr, Notification: DriverFailed

Permission problem possibly with access /dev/ttyAMA0. Do a “ls -lag /dev/ttyAMA0” make sure that whatever user is running HA is part of the group for the serial port…barring you’re not running as root…then it’s a different problem.

Many thanks ski522. Output as follows, but I’m none the wiser at this point. I also tried a new install using Hassio on a different SD card. Exactly the same problem…

pi@hassbian:~ $ ls -lag /dev/ttyAMA0
crw-rw---- 1 dialout 204, 64 Sep 30 19:37 /dev/ttyAMA0
pi@hassbian:~ $ whoami

Hassbian is installed in a virtual environment: https://www.home-assistant.io/docs/installation/hassbian/installation/#technical-details

As ski522 mentioned, it’s minimum a problem of r/w access to the z-wave stick.

  1. you need to disable the on-board Bluetooth on a Pi3

  2. follow the instructions in the last link (check configurations, folders …)

“sudo cat /etc/group |grep dialout” if you don’t see pi listed as user then add it.

“sudo nano /etc/group” look for dialout and add the following so it looks like “dialout:x:20:pi” reboot Pi. If there is a user listed separate the next user by “,” for example “dialout:x:20:pi,user1”

Done that, but all looks good:

pi@hassbian:~ $ sudo cat /etc/group |grep dialout

Thanks Honikos and ski522. We’ve cracked it! Disabling the Bluetooth per Honikos’ point 2 and checking the permissions fixed the issue. I was under the impression that you do not have to disable bt on the pi3B+ as opposed to the pi3.

We live and learn and I’m very grateful to you both.

Good to hear. Probably bt was the main issue since HA is probably running using the user homeassistant. Won’t hurt keeping pi in as a user in the dialout group though…sometimes as the saying goes, if it works don’t fix it!