Z-wave issues - HassOS Aeotec Gen5 z-stick

Apologies if this is in the wrong place, please guide as I’m new with HassIO - working on a migration from Indigo on macOS to HassIO

Running Pi3B+ with HassOS 2.12 with a fresh install and Aeotec Gen 5 Z-stick

HassIO loads up, finds my HomeKit and Sonos devices. I added the Z-Wave integration, pointed to the usb stick identified in the hass.io->system->hardware…Z-wave loads correctly and finds the z-stick. It took a while but it finally loaded devices, but not all of them. Thats the problem and i can’t get it to load all of them no matter what. I’ve stopped, restarted, healed the network etc…I’ve searched around and can’t seem to find a post with this particular problem.

How do i get the rest of the devices that are on the stick to show up as devices and usable?


  1. I know they devices are properly paired with the stick and functioning. I’ve had the z-stick installed on MacOS/Indigo. all devices work properly there. When I pull the device and plug it back into the mac all works well. I plug it into to HassIO, restart the Pi3B+ and it finds about 2/3’rds of my devices but not all.
  2. These are all powered devices, leviton switches wired in, plug adapters, etc. No battery operated devices. The ones that work are also wired in as well…so no pattern there.
  3. I can see the missing devices in the OZW logs as it says “Z-Wave node xx not ready after 30 seconds, continuing anyway” but it never “connects” as the devices don’t show in the control panel. Although some do. the XX nodes are the missing devices.

Any help is appreciated.

Can you see the nodes defined in the zwcfg*.xml file? Stop HA or click on “Save Config” in the control panel to write the cache to the file, then post it on a pastebin, it might show something. I am guessing they are there, but are nearly empty.

Restart HA and after the network has finished starting, post the OZW_Log.txt, that also might hint at something.

Many devices will send a “node info” message (NIF) if you press some specific button combination on the device (e.g. double toggling a light switch, pressing a special button, etc), often that is the inclusion process. Try repeating the inclusion process (without doing “Add Node” on the controller) to see if the node will send its info to the controller (or look in the manual if there is a way to force send what is called an NIF).

pardon the ignorance on HA, when you say the cache file, is that the content of the OZW log file?

i have a lot of these messages in the OZW log after hitting save config

2019-10-28 19:12:46.193 Info, Node028, ApplicationCommandHandler - Unhandled Command Class 0x84

and this

2019-10-28 19:44:00.357 Info, Node023, ApplicationCommandHandler - Unhandled Command Class 0x82
2019-10-28 19:44:01.948 Detail, Node023, Received: 0x01, 0x08, 0x00, 0x04, 0x00, 0x17, 0x02, 0x82, 0x01, 0x65
2019-10-28 19:44:01.948 Detail,
2019-10-28 19:44:01.948 Info, Node023, ApplicationCommandHandler - Unhandled Command Class 0x82
2019-10-28 19:44:02.544 Detail, Node023, Received: 0x01, 0x08, 0x00, 0x04, 0x00, 0x17, 0x02, 0x82, 0x01, 0x65
2019-10-28 19:44:02.544 Detail,
2019-10-28 19:44:02.544 Info, Node023, ApplicationCommandHandler - Unhandled Command Class 0x82
2019-10-28 19:44:08.408 Detail, Node023, Received: 0x01, 0x15, 0x00, 0x49, 0x84, 0x17, 0x0f, 0x04, 0x10, 0x03, 0x25, 0x27, 0x2b, 0x2c, 0x85, 0x72, 0x86, 0x91, 0x77, 0x73, 0xef, 0x82, 0xa4
2019-10-28 19:44:08.408 Detail,
2019-10-28 19:44:08.408 Info, Node023, UPDATE_STATE_NODE_INFO_RECEIVED from node 23
2019-10-28 19:44:08.408 Detail, Node023, AdvanceQueries queryPending=0 queryRetries=0 queryStage=Dynamic live=1
2019-10-28 19:44:08.408 Detail, Node023, QueryStage_Dynamic
2019-10-28 19:44:08.408 Detail, Node023, QueryStage_Configuration
2019-10-28 19:44:08.409 Detail, Node023, QueryStage_Complete
2019-10-28 19:44:08.409 Warning, CheckCompletedNodeQueries m_allNodesQueried=1 m_awakeNodesQueried=1
2019-10-28 19:44:08.409 Detail, Node023, Notification: NodeQueriesComplete
2019-10-28 19:44:09.393 Detail, Node023, Received: 0x01, 0x08, 0x00, 0x04, 0x00, 0x17, 0x02, 0x82, 0x01, 0x6

both of these nodes aren’t showing up as devices

And node 28 is the same brand/model of other switches that show up and work properly

node 23 shows up in the zwcfg*.xml file

    <Node id="23" name="" location="" basic="0" generic="0" specific="0" type="" listening="true" frequentListening="fa
            <Manufacturer id="0" name="">                  
                    <Product type="0" id="0" name="" />                                                                
            <CommandClasses />                                                        

As far as I am aware Openzwave supports these classes. Everything should be working.
It is possible you may need to exclude and re-include the devices in question.

The empty product name and ID is why you’re seeing those “Zwave node not ready messages”. Somehow, OZW was not able to get information about those nodes. You could try stopping HA and removing the XML for the empty nodes, and see if they are recreated properly.

That snippet of logs doesn’t tell much, it would be more helpful to post the entire contents of OZW_Log.txt after restarting HA.

thanks, I’ll try to do that this evening

Thank you for the help, learning this as i go
so i’m new to pastebin as well… pardon the mistakes if this isn’t working


I deleted the integration, restarted HA, re-added the integration to clear everything. Pretty much the same result. Same devices show up. same devices are missing

What are those devices? Are any or all of them secure nodes or added securely? Do you have a network security key configured in the software when you plug the Z Stick into the Mac and did you transfer that key over to HA?

During startup some commands are already failing. There are a lot of message timeouts to various nodes.

2019-10-28 21:32:10.094 Info, Node031, Sending (Send) message (Callback ID=0x47, Expected Reply=0x04) - SwitchMultilevelCmd_Get (Node=31): 0x01, 0x09, 0x00, 0x13, 0x1f, 0x02, 0x26, 0x02, 0x25, 0x47, 0xbe
2019-10-28 21:32:11.094 Error, Node031, ERROR: Dropping command, expected response not received after 1 attempt(s)
2019-10-28 21:32:11.094 Detail, Node031, Removing current message
2019-10-28 21:32:11.094 Detail, Node031, Notification: Notification - TimeOut

Then a lot of these start appearing:

2019-10-28 21:31:37.678 Detail, Node009,   ZW_SEND_DATA delivered to Z-Wave stack
2019-10-28 21:31:37.679 Detail, Node009, CAN received...triggering resend

Likely these timeouts and CAN errors are resulting in OZW being unable to query the missing nodes for their information.

These can indicate RF interference or network congestion (see here). Is the location of your Z-stick any different then when it was installed in the Mac? It could be as simple as finding a better location for the stick.

Squirtbrnr, the locks are the only secured devices. Those show up but don’t work. And i did not transfer the key from the Mac over to HA. I’ll try that to see if it makes a difference


I really appreciate the help.

The RPi 3 & z-stick are sitting next to the Mac. That’s why I find it odd the Mac/Indigo setup works well with all nodes, but the RPi3 with HassIO does not. I expected the locks to have trouble until the network key is moved over, but not the rest of the devices.

For context…
Example of working devices:

  • 3 of switches are about 10 ft away from the z-stick with line of sight.
  • 4 more switches are in the kitchen, 20 ft away (no line of sight)
  • 1 switch on the stair well (with a remote switch at the top of the stairs)
  • 2 switches in an upstairs room (furthest away from the z-stick)

Non-working devices:

  • 1 Outdoor GE Appliance Module, on the patio just on the other side of the door from the 3 working switches mentioned above
  • 1 switch (same model is the 10 working switches) is upstairs about half way between the media room and the z-stick.
  • 5 lamp modules (4 dalton’s & 1 aeotec) placed around the house in various places upstairs and downstairs

You might be curious as to why I haven’t copied the network key. Basically playing around with the core components, testing stability etc before i go all in on HassIO. The family has gotten dependent on the home automation, alarms, lights etc so its hard to go “all-in” until i know I can get everything working.

I really want the HassIO set up to work as i like the UI and the ability to put tablets around the house with the dashboards (way better than Indigo) plus eventually moving from envisalink to the konnect.io security system.

One more note. I un-paired the upstairs switch (same model as the ones that work) and re-paired with the z-stick.

The switch still did not show up, but another device did…partially. It shows up as an un-known node

More info in case it helps, I’ve installed HassIO on various platforms with varying results.

First on a mac, this was my initial proof of concept. I’m pretty sure all of the devices showed up. I know the outdoor appliance module did. This was a Macbook, so it won’t be around all the time…thus the reason to move to something more permanent. And i want to get rid of the old macmini where indigo is running

Second, i installed on a linux-Mint VM on esxi. That worked fairly well. Most, but not all, devices showed up, never did much troubleshooting as the UI was different, namely no hass.io panel and no add-on store. Thats why I started with RPi

Third, initially got the RPi4 but it didn’t work with the z-stick at all. That’s a completely different story.

Finally got the RPi3. All seemed great on initial install. add-on store was there, z-stick was recognized, devices started showing up, then realized not all z-wave devices were there. I was initially using a USB plug for power, while the z-stick showed up, it didn’t find any devices. Had the idea of using the actual power supply that came with the device and voila, devices started showing up…but not all of them. Then troubleshooting started which ultimately lead to this thread.

Thanks to everyone looking into this.

Raspberry has problems with the Z-Stick and the USB port. With a USB Hub I am doing fine.

You’re right! :slight_smile: Are you saying that the Indigo install uses a different network key than the HA install? You previously said you’re using the same Z-stick with the same network right? From your logs, it shows this:

2019-10-28 21:30:19.161 Info, Setting Up Provided Network Key for Secure Communications

So even if you didn’t install the Indigo network key, HA created a new one for you. This means the HA configuration is using an incorrect key, in relation to the already included secure nodes. There is no downside to installing the correct network key. If you are evaluating HA to replace Indigo, wouldn’t you want to verify that your locks and other secure devices are functioning correctly? Those would be the most important in my mind.

If I were you, I would update your config to use the correct key. You’d need to stop HA, delete the zwcfg*.xml cache file, edit either the configuration.yaml to include the network key, or fix the zwave integration to use it (delete it and add it again, or edit .storage/core.config_entries and replace the key) and try again.

Is the wrong network key is causing your problems? Maybe not, since you tried with other install methods with various results, but at least fixing it would exclude that as a problem. If there is no improvement at least you’ve eliminated one difference between Indigo and HA.

Did you install Hassio from the RPi image, or did you install it manually on an existing Debian/Ubuntu install?

As far as I know that’s only an issue with the RPi 4. I’ve bveen using an Aeotec Z stick for over two years and the first year of that was on a RPi 3b without issues.

Yes Indigo and HA both generated their own network keys. The only secure nodes i have are the locks, so I wasn’t too worried about those yet until i got everything else working. Ironically, the locks show up…they just don’t work; which is expected since i didn’t fix the network key. I’m actually surprised they showed up.
And yes, ultimately, i do want to make sure the locks work. just more worried about the other items first. I just figured i might have to un-pair and re-pair to get them to work properly.

I installed HassIO from the RPi image 32-bit, I actually tried 64-bit as well to see if it would work better with the z-stick, but didn’t see a difference so went back to the recommended 32-bit.

Thanks for the suggestions, i’ll give those a shot tonight

Ironically, the locks show up

That probably ruins my possible theory!

I just figured i might have to un-pair and re-pair to get them to work properly.

That’s correct. Easier to just use the same key. :slight_smile:

I installed HassIO from the RPi image 32-bit, I actually tried 64-bit as well to see if it would work better with the z-stick, but didn’t see a difference so went back to the recommended 32-bit.

I only asked because there is a problem if you have modemmanager installed. I don’t believe it would be installed with HassIO, but you could double check. 32 vs 64-bit shouldn’t matter, but I’ve only used 32.

Unfortunately I’m running out of ideas. If you don’t get any more suggestions here and have the strength to continue, you could try in the zwave Discord channel or try your luck on the OpenZWave mailing list.

thanks for all the help. Gave up on doing it the “easy” way and decided to un-pair all the devices and reset the z-stick, then re-pair all the devices.

Now on to a different set of problems…still z-wave

All of the devices now show in the device list (except the locks, haven’t done those yet) but they only show the z-wave symbol. The switch part of the entity isn’t showing up so you can’t actually control the device. So its useless…unless there is a learning opportunity here. Last time, that just showed up for thoe ones that worked


1 Like