Z-Wave JS Aeotec WallMote Quad Migration

After migration Z-Wave, followed instruction Z-Wave legacy (1.4) -> Z-Wave JS Official add-on. Most of the devices are able to detect normally but Aeotec WallMote Quad(ZW130). Digging some posts, here is what I did.

  1. Press and hold the action button in the back of the ZW130 for 2 secs until the orange led flash. Get into wake up mode. You could check the log under Z-Wave JS add-on to see it completes the interview process… Picture
  2. (option) In Developer Tools, you could check the events and listen to "zwave_js_event ". Press any button on the ZW130 and the event should pop out.
  3. I used automation to manage the buttons.
    Example: touch Button 1
platform: event
event_type: zwave_js_event
  node_id: 17
  label: Scene 001
1 Like

After upgraded the OS to 2021.3.0 and Z-Wave JS to 0.1.10, it seems the zwave_js_event has changed. The message is now property_key: "001" instead of label: Scene 001

1 Like

I just moved to the zwave js add-on and the WallMote is one of the few items that is stuck in “Node Awake: No.” status. When I put mine into wake up mode, by holding the button until it flashes orange, I get :

11:51:48.653 CNTRLR « [Node 014] received wakeup notification

I’ve left it flashing orange for 10 minutes, but nothing else is showing in the logs. How long did it take for yours to wake up and join?

UPDATE: I ended up just doing a reset on the WallMote and then rejoining the network and that worked just fine.

Updated the OS to 2021.4.1 and JS to 0.1.17. The Wallmote isn’t working anymore. After change the event value from zwave_js_event to zwave_js_value_notification everything goes fine now.

platform: event
event_type: zwave_js_value_notification
  node_id: 17
  property_key: '001'

With ZWave JS do you have only this 4 button?
Before there where also the “long” button?

Would also like to know if the long-press still works as I currently use that.
Also is this actually compatible, as the device isnt listed on the ZWave JS device list

Yes this device is still supported by zwavejs.
Here is a link if interested.

Here are a couple of other threads that may help out:

1 Like

Thank you so much!

I can’t get this working at all… i have tried re-connecting it 20 times but i just get the battery status, and nothing from the bottons. When i try to listen to “zwave_js_event” there is nothing displayed.
How did you guys solve it? Using Zwave JS.

WallMote Quad: Battery level
100,0 %
WallMote Quad: Low battery level
WallMote Quad: Power Management - Battery is charging
WallMote Quad: Power Management - Battery is fully charged
WallMote Quad: Power Management - Charge battery now
WallMote Quad: Power Management - Charge battery soon


Edit, nevermind! I tried one more time and then i wen’t to the logs, and i saw it there! Works awesome :smiley:

Is it possible to use slide functionality in Z-Wave JS?

1 Like

I’ve not been able to get this to work and it seems to post no notifications when listening on ‘zwave_js_value_notification’ but if anyone has been able to get this to work would love to hear

I have changed to use the blueprint from
It is very easy to import and works great for me . I haven’t met any issue for almost a year.

I’d also like to see slide functionality working in home assistant. It works well using Hubitat (using a script) but since I’ve migrated over to HA I can’t see how I can get this to function.

1 Like

Please elaborate. What do you see in the logs? I too have only the 5 or 6 entities connected to battery status. Where do I find my node Id and buttons?

Hmm well, i can’t really remember now how i did it or what logs i checked, since it was some problems away… but i use this blueprint to controll the WallMote, and it works perfect. Try if it solves you’r problem.

It works with the blueprint. Piece of cake
BTW listening to the events requires the event type zwave_js_value_notification
HA 2021.12.3

1 Like

Slide does not work because no event is fired. The device when interviewed never shows it supports MultilevelSwitchCC. When you start the swipe up on the remote it sends a MultilevelSwitchCC::StartLevelChange with direction “up” and when stop swiping it sends a MultilevelSwitchCC StopLevelChange. When you start swiping down it sends a MultilevelSwitchCC::StartLevelChange with direction “down” and when you stop it sends a MultilevelSwitchCC StopLevelChange.

How do we force a device to have a given command class? I can’t pick MultilevelSwitch even after re-interview.

Here’s a snippet from the logs.

–Start Swipe Up
2022-12-16T08:37:43.912Z DRIVER « [Node 079] [REQ] [ApplicationCommand]
startLevel: 0 (ignored)
direction: up
duration: 2s
2022-12-16T08:37:43.915Z CNTRLR [Node 079] treating MultilevelSwitchCC::StartLevelChange as a notification
2022-12-16T08:37:43.917Z CNTRLR [Node 079] [Notification] Multilevel Switch
event type: Start level change
direction: up

–Stop Swipe Up
2022-12-16T08:37:45.213Z DRIVER « [Node 079] [REQ] [ApplicationCommand]
2022-12-16T08:37:45.215Z CNTRLR [Node 079] treating MultilevelSwitchCC::StopLevelChange as a notification
2022-12-16T08:37:45.216Z CNTRLR [Node 079] [Notification] Multilevel Switch
event type: Stop level change
direction: undefined

The log snippet shows the device is sending the documented Multilevel Switch commands, the controller receives it, and sends its own Start level change, and Stop level change Notification events. Did you try listening for zwave_js_notification events in HA?