Z-Wave JS Devices Unresponsive After 0.2.1 Update – Looking for Troubleshooting Tips

I’m experiencing some issues with my Z-Wave JS integration and could really use your help. My setup was running smoothly until the recent update to Z-Wave JS version 0.2.1. Now, all my devices are unresponsive.


  • When I ping any device from the device info screen, I can see it update in the logbook.
  • However, switching devices off and on doesn’t register anything in the logbook.

What I’ve Tried:

  • Rolling back to version .089 temporarily fixed the issue in the past, but with the 0.2.1 update, it’s back, and I’d rather not roll back again.
  • Checked logs for any obvious errors or warnings, but nothing stands out.

I’m looking to address the root cause and could use some suggestions on troubleshooting steps or potential fixes.

Thanks for any help you can offer!

Well just rolled back to Core 2023.8.1 and Z-Wave JS 0.1.90 and my Zwave devices are working again however I now have issues with My Life360 and SmartThings integrations . Be nice if I could update and not lose my z-wave functionality. Is there anything in the update that is known to be cause issues. I am running HA on a VM under ESxi.

What kind of coordinator stick? If it’s a 500 series stick did you see the note about ensuring that Soft Reset is disabled for 500 series coordinators when used in conjunction with a VM?

Where is that note? I’m now quite wary about updating HA because it seems like something major breaks pretty frequently, and I want to make sure I’m safe. I run my HAOS on a VM and see that I have not disabled Soft Reset, but then again my version numbers don’t match with the OP’s version either:

zwave-js-ui: 9.2.3
zwave-js: 12.2.1

I have a pending update for Z-Wave UI 3.0.0 and have been iffy on pulling the trigger on that because I have way too many devices to have them go down at 5PM on a Friday :slight_smile:



Tks @NathanCu I have a Aeotec Z Stick Gen5. I have looked for an area under the configuration in HA & SSH’d into HA but I don’t see where to set this parameter, “soft_reset”: false. Can you point me to where I might find an article on this or might I be overlooking something obvious?.

Zwave JsUI console
Hamburger menu
Settings (gear Icon)
ZWave section

About halfway down on the right.

In short on a 500 series controller and the Aeotec in particular. If you have soft reset enabled (which is the software equivalent of yanking out the USB stick and reinserting it) and are using a hypervisor (VM) then when the soft reset occurs the system can’t guarantee that it gets the same virtual is pot when it comes back online. (ttyama0/1 etc) and as far as JS_UI is concerned (because it’s manually setup with a path to the stick) your stick jumps ports. And the addon can’t address it anymore. (net effect JsUI stops or crashes)

To prevent this behavior. If you’re using a 500 stick on a hypervisor.

  1. turn off soft reset to prevent the stick being bounced in the first place
  2. use the full by-id path to the stick instead of the virtual port (ttyama0/1) when configuring ZWave JS UI
1 Like

I have exactly the same issue… i have to reboot my HA every 8 hours to make it working again…
So, I have changed the config from automatic to none, but no chance : I still have the issue…


it’s so anoying, I expect a correction soon…

In addition, I,m not in a VM : i’m running it in a Raspberry Pi 4 and for the usb, I have no other choice than:

I bit the bullet and updated, making sure to turn off soft reset and it totally bombed on me after about 2 hours where all Z-Wave was offline. I restarted the entire system (or virtual machine in my case) and it’s been solid since. I’ve been waiting to see if it pooped out again but so far so good.

1 Like

Revert back to 0.2.0 : still have the issue… it disconnect after some few hours…

Is your dongle:

  • On a USB extension
  • Plugged into a powered USB hub

If no on either of those then that may be the issue. I assume you totally powered off your pi, even moved the USB to a different port and got the same results?

1 Like

The usb stick is directly connected to a port of the raspberry Pi hardware.
To make it work again (for a few hours…) I had to reboot physically the raspberry….

This is a known problem. The USB bus on RPis are very noisy (esp in the 2-3 Ghz band - like hammers zigbee and ZWave sticks)

At the very minimum a USB extension cable is necessary to reduce the noise. Preferably a powered usb 2 hub plugged in to one of the USB2 (read: not blue or orange) ports.

And yes it can absolutely knock out comms.

1 Like