Z-Wave JS Error = Failed

Hi all. Currently facing an error preventing inclusion of z-wave devices with an Aeotec ZStick 7 via Z-Wave JS getting the following vague error in the logs. It is worth noting i can include devices via PC using Simplicity Studio 5, and connections behave as expected. Moving the z-stick back to HA shows the new nodes, but no traffic occurs, and the sensor values never update:

2023-07-07 00:31:32.748 INFO Z-WAVE: Success zwave api call startInclusion true
2023-07-06T14:31:39.984Z CNTRLR handling add node request (status = NodeFound)
2023-07-06T14:31:42.662Z CNTRLR handling add node request (status = Failed)
2023-07-06T14:31:42.665Z CNTRLR Adding the node failed
2023-07-07 00:31:42.666 INFO Z-WAVE: Controller status: Inclusion failed
2023-07-06T14:31:42.668Z CNTRLR stopping inclusion process…
2023-07-06T14:31:42.713Z CNTRLR The inclusion process was stopped
2023-07-07 00:31:42.714 INFO Z-WAVE: Controller status: Inclusion stopped

What machine are you running HA on?
How is your Zstick connected to it?
Do you have the latest firmware on the stick?

Sorry for omitting that detail. I am using a HA yellow (non POE), with the z-stick connected via usb (have tried both ports with the same outcome). And yes i have upgraded to the latest z-stick firmware of 7.19.2.

To add to my comments, i had previously been using an Aeotec Z-Stick gen5+ on the same port in the same location (in a server rack) with no issues, other than the odd delay on a sensor updating.

I have read several posts indicating that interference can cause similar symptoms, so i used a usb extension cable to remove the Z-Stick 7 from the “noisy” environment, and had exactly the same error.

and here are some additional detailed logs
2023-07-06T23:26:52.342Z CNTRLR Starting inclusion process with strategy Default…
2023-07-06T23:26:52.380Z CNTRLR The controller is now ready to add nodes
2023-07-07 09:26:52.385 INFO Z-WAVE: Controller status: Secure inclusion started
2023-07-07 09:26:56.546 INFO APP: GET /health/zwave 200 2.394 ms - 2140
2023-07-07 09:27:26.704 INFO APP: GET /health/zwave 200 2.447 ms - 2140
2023-07-07 09:27:56.892 INFO APP: GET /health/zwave 200 3.196 ms - 2140
2023-07-06T23:27:59.903Z CNTRLR handling add node request (status = NodeFound)
2023-07-06T23:28:02.672Z CNTRLR handling add node request (status = Failed)
2023-07-06T23:28:02.673Z CNTRLR Adding the node failed

I realized i had a second “700” receiver, which was a hubitat-branded z-wave module. Same silicon labs chip. Upon testing, it shows exactly the same symptoms. Works fine on PC with the Simplicity Studio software, where i can add and exclude devices without issue, but Z-Wave JS UI fails.

So this begs the question, is there a general compatibility issue with the 700-series controllers?

Hi all. Wondering if anyone is experiencing the same issues as I am, or have advice on how to proceed from here.

Based off your statements you have (2) problems.

  1. You can’t include devices in with the Z-Stick 7 Using Z-Wave JS UI
  2. When you include devices using the PC Controller software and move the stick back to HA, you can see the new nodes, but no traffic occurs, and the sensor values never update.

My Solutions

  1. Have your tried using a USB extension cable? Also I would try using other versions of Z-Wave JS UI to see if the issue persists. I personally use the standalone version of Z-Wave JS UI for this because of how easy it is to migrate from one version to another. I simply double click on the executable to start the version I want to use. All of the settings and stuff are stored in the store folder so you DON’T have to reconfigure anything when jumping between versions. If the issue is truly a Z-Wave JS UI you can open up a support ticket here.

Z-Wave JS UI Standalone

  1. The reason the devices you added via the PC Controller Software are not communicating when you switch back HA has to do with the security keys. There are (2) sets of security keys. The ones built into the controller and then the ones that override the built in keys. In the PC controller software it will default to the built in keys while in Z-Wave JS UI it will just override the built in keys. Both devices must use the same keys or they won’t be able to decrypt each others messages. The security keys are sent to a device during inclusion so the only way to update them is to exclude the device and reinclude it. This is why I just copied the built-in keys from the PC Controller Software to my Z-Wave JS UI install. This way I can switch back and forth between both programs without encountering this problem. You can view and set your security keys in the PC Controller Software by clicking the shield icon in the top right corner.

Thanks so much for the detailed response. In answer to question 1, I have indeed used a USB extension cable, and attempted the process with Z-wave JS and Z-wave JS UI, however none of these steps changed the outcome.

The inclusion process followed to add devices via the 500-series z-stick works flawlessly, the 700-series (both of them) error out. That has me miffed.

I will attempt your recommended steps and see if anything leads to a solution.