Z-Wave JS Fan Entities Not Exposing to Alexa via Nabu Casa

I recently switched from the Z-Wave (deprecated) integration to Z-Wave JS (not MQTT). Ever since I’ve switched, I cannot get any of my GE or Homeseer Fan Switches to expose themselves to Alexa. I’m using Nabu Casa, and have the entities exposed in the Nabu Casa Alexa configuration. I’ve tried un-exposing them, deleting everything in Alexa, exposing them, then syncing them. And all combinations that I can think of in between. Does anyone have any advice on where to start looking, or do I need to bring this up to the developers?

Home Assistant 2021.10.6
Home Assistant OS 6.5
Z-Wave JS - Firmware: 0.1.45
Aeotec ZW090 - Firmware 1.1
GE 12730 - Firmware 3.10
GE 14287 - Firmware 5.20
Homeseer HS-FC200+ - Firmware 50.5
Z-Wave JS Driver Version: 8.4.1
Z-Wave JS Server Version: 1.10.7

Make sure you are exposing the Fan domain to Alexa in Home Assistant Cloud

I believe I remember seeing somewhere on here that it was a known bug.

Maybe you can find it.

Do you know if it was a Nabu Casa bug, Home Assistant bug, or a Z-Wage JS bug?

I honestly don’t remember.

And TBH, I could be misremembering completely since I can’t find anything about it.

There was a bug indeed related to Alexa not supporting fan speeds with a decimal point (only integers). I believe max speed is technically 99 so 3 speed fana should be ok, while 4 speed no (99/4), but none of mine qere qorking (both 3 and 4) however one of the last November updates fixed it for me. There is a related fix in today’s upate too.