Z-wave js no network key?


I have migrated from z-wave integration to z-wave JS. During the migration process I had some issues and decided to re-add some devices. I did copy my network key and added it during the begingng of the process as per documentation.

All my devices are up and running except one, my danalock. After going through the logs I can see the following error:

2021-09-05T22:14:22.470Z CNTRLR   [Node 056] Beginning interview - last completed stage: None
2021-09-05T22:14:22.471Z CNTRLR   [Node 056] new node, doing a full interview...
2021-09-05T22:14:22.471Z CNTRLR » [Node 056] querying protocol info...
2021-09-05T22:14:22.486Z CNTRLR « [Node 056] received response for protocol info:
                                  basic device class:    Routing Slave
                                  generic device class:  Entry Control
                                  specific device class: Secure Keypad Door Lock
                                  node type:             Routing End Node
                                  is always listening:   false
                                  is frequent listening: 1000ms
                                  can route messages:    true
                                  supports security:     false
                                  supports beaming:      true
                                  maximum data rate:     100000 kbps
                                  protocol version:      3
2021-09-05T22:14:22.487Z CNTRLR   [Node 056] Interview stage completed: ProtocolInfo
2021-09-05T22:14:22.487Z CNTRLR » [Node 056] querying node info...
2021-09-05T22:14:23.779Z CNTRLR « [Node 056] node info received
                                  supported CCs:
                                  · Z-Wave Plus Info
                                  · Security
                                  · Security 2
                                  · Transport Service
                                  · Manufacturer Specific
                                  · Time
                                  controlled CCs:
2021-09-05T22:14:23.794Z CNTRLR   [Node 056] Interview stage completed: NodeInfo
2021-09-05T22:14:23.795Z CNTRLR   [Node 056] supports Security S2, but no network key was configured. Continuing
                                   interview non-securely.
Error in driver ZWaveError: Node 056 supports Security S2, but no network key was configured. Continuing interview non-securely.
    at ZWaveNode.interviewCCs (/usr/src/node_modules/zwave-js/src/lib/node/Node.ts:1577:8)
    at ZWaveNode.interview (/usr/src/node_modules/zwave-js/src/lib/node/Node.ts:1263:19)
    at Driver.interviewNode (/usr/src/node_modules/zwave-js/src/lib/driver/Driver.ts:976:10) {
  code: 28,
  context: undefined,
  transactionSource: undefined

As far as I can see it does not recognize the entered network key and tells me there is no network key at all?

I have entered the network key as seen below (totalt 32 chars long):

Any idea what is wrong and how to fix this?

Please see if this helps you in any way:

Hi, I did as you suggested and added the key to all four places, and get the following error:

2021-09-06 13:46:13.409 INFO ZWAVE: Controller status: Driver: The security key for class S2_Authenticated was used multiple times!
2021-09-06 13:46:13.410 WARN ZWAVE: Retry connection in 3 seconds

Stupid question, but do I need to disable the “normal” z-wave JS plugin or can I use that parrallel with the mqtt one?

It is just an informational warning that you used the key multiple times. The magic should be in using the include button from within Home Assistant and not the Z-Wave JS MQTT panel. And no, only 1 addon/plugin can be used at the same time.

I never managed to connect the MQTT plugin to the client, it failed to connect when I tried to reasing server to the new address in the documentation.

BUT, I bit the apple and took down my lock (I have modified it to be on PSU instead of batteries) and took it down to the basement to the controller and redid the inclusion process (z-wave JS without MQTT) and now it worked.

Funny thing is that I took my controller (aeotec z-wave stick) to the lock and tried to do a pairing using the sticks pairing function and that failed too…

So long story short, make sure the danalock is really close to the controller during pairing and use the tool under "configuration > integration > and choose “configure” under z-wave JS integration.

Good to read it’s working now. The pairing function of the stick itself shouldn’t be used, as it tends to create more problems than solve them :wink: Probably the reason why new controllers no longer have batteries hehe.

1 Like