Z-Wave JS - NodOn Z-Wave Remote


This is a blueprint for the Nodon Z-Wave remotes (Octan and Soft) wth Z-Wave JS.

Based on @gsemet blueprint, I added support for double/long/release press and the Octan remote

Open your Home Assistant instance and show the blueprint import dialog with a specific blueprint pre-filled.
see last blueprint yaml file

1 Like

Thanks, I still use old Z-wave integration so can’t use your blueprint, but good to know there is one for the future.

This blueprint is working perfect. Initially it refused to work but as a result of some research I discovered that the parameter “Scene Type” was set to “Activation” by the factory, not by me. After I changed is to “Central Scene” it works. Thanks a lot for this blueprint!

1 Like

Hi all

I’m new to HA so please excuse my lack of competence.
I have added my Nodon Soft Remote without any problems (I hope)
I can see the logs when I press the buttons.

When I try to use this Blueprint I get “No matching devices found”.
Any hints on what I’m doing wrong?


You have to check if the device match this:

integration: zwave_js
manufacturer: ID-RF

Thank you.
How can I find this info?
if I look under “devices” it says manufacturer: ID-RF, integration: z-wave
I’m running Z-Wave JS

that’s weird, try to remove line 10 to 13 https://github.com/Aohzan/hass-blueprints/blob/87209ae2617b8523e5779a02214a19a946252ed6/blueprints/nodon-zwave-remote.yaml#L10-L13

Sorry, I get the same result.
“No matching devices found”