Z-Wave JS to MQTT - sleeping devices no longer working

After updating from 0.37.0 to 0.39.0 all of my devices that are not always on show as ‘ProtocolInfo’ in the UI of Z-Wave JS to MQTT and are inoperable from my Home Assistant dashboard. I ran into this same issue when upgrading to 0.38.0, so I reverted back in that case, but at some point I think I may need to upgrade to ensure compatibility with Z-Wave JS (after the most recent update it started reporting an error and none of my Z-Wave devices worked).

So, two questions:

  1. Is there a simple way to get my devices back? I tried to wake one up (a water sensor, by putting water on the sensor) but no luck in getting it to report.

  2. If not, is there a simple migration path to the default Z-Wave JS integration?


Is it possible the devices were being interviewed and needed to be awakened to complete interview successfully? (that’s what protocolinfo says - the node/device is currently being queried for protocol information)

Did you try to wake one of those sleepy devices by a physical button or some similar while it was in that state?

How long did you wait (most sleepy devices wake at least once per day) before you called it and rolled back?

Hello, I had the same problem. I tried several times, maybe three or four, to update it. Always I need to play back the backup. Luckly that works perfect. I also tried to wake the devices up, with no sucess.
What I did, two days before, is to disable the “soft reset” in the zwave settings before I start the update from 0.37 to 0.39. I m not sure if this was the problem but then the update works fine and smooth.
Maybe try this?
Good luck

1 Like

That works, thanks!