Z wave locks not functioning


I am trying to migrate away grom Wink hub and get my devices on a USB z wave device. So far I have had success with light switches, a Jasco fan control that was first a light dimmer then turned into a fan and Schlage door sensors. I do have 3 Schlage locks and a Yale lock, all with z wave+ and keypads.

The locks are an issie. No problem with inclusions, very easy. But both the Yale and the Schlage do not do anything. The main function lock and unlock does not work.

I am sure there is a log to post but not sure which or where it is. Can someone please help, I can always go back to the Wink hub but would rather sort this out.

If you are unable to lock/unlock they didn’t pair securely. Exclude them from the network and re-include them via the Add Secure Node button.

Do not use the secure add for things like light switches and such unless their manually explicitly states it’s required to avoid Zwave network latency issues.

Note: If Add Secure Node is missing, your zwave network doesn’t have a key setup.

1 Like

I did use add secure but will try this. I read some online documentation that said when you use add secure if the device does not use it, it defaults to regular inclusion. Might have to start from scratch…had weird issue at first with this USB stck and it is my third attempt with USB z wave. Should maybe be a new thread but here is how my install went and I had replicated it exactly about 5 times…

#  usb_path: /dev/ttyUSB0
#  config_path: /usr/local/share/python-openzwave/config
#  polling_interval: 10000

That is in my config.yaml, it is uncommented because was only way to get the USB device inititated. I had to uncomment it after it was finally recognized, happened by fluke but repeated several times, only way it would work. If I comment it, I lose te USB device under integrations. Seems very odd to me as I havent seen this method anywhere!

under integrations it says Z-wave: Z-wave (import from configuration.yaml)

While this is true, some devices support it but it isn’t required, if I recall there’s a brand of light switches that supports secure inclusion, all that does is it’s response time.

It’s looking to your configuration.yaml for the key then, and based on what you’ve posted there’s no network key listed :wink: Exclude your locks, add a key to your configuration.yaml, restart HA, then include the locks, should fix you right up.

1 Like

thank you, will do after researchung how to do that!

Here’s the link to the docs for that :slight_smile:

1 Like

found that lickity split thanks though, 1 more thing, like Columbo, the format 0x01, 0x02…does the character “x” need to remain or does it just to be a letter ie; number letter number number, or does it matter? I think I will have new problems with it unblocked though…

It needs to remain, there’s a section in the docks with instructions on how to best generate a random key for yourself :slight_smile:

1 Like

ok, so as I expected, I have “lost” the USB z wave device under integrations. I know if I # the lines I will have it back after a restart but cant imagine I will have network key functionality? Althougbh this while process I use does not add up, all I know is it was working… for the most part

Are you running HassOS and/or Home Assistant Docker?

If so, check the Hardware menu for a list of paths to the serial devices, should be one in there looking like /dev/blah/blah/by-id/DeviceNameorSerialNumber-if00 you’ll place that in the configuration.yaml file.

1 Like

gonna have to tap out soon…lol
Hass OS 3.9 Docker: True
Running on a RPi

Do I have 2 entries because I may have inadvertently changed ports? But they both say port 0??

  • /dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_813009FF-if01-port0
  • /dev/serial/by-id/usb-Silicon_Labs_HubZ_Smart_Home_Controller_813009FF-if00-port0
  • /dev/ttyAMA0
  • /dev/ttyUSB1
  • /dev/ttyUSB0

Try this one as your usb_path in the config. If that doesn’t work it could be the if01 device.
You see 2 devices as 1 is for the zwave radio, the other is for the zigbee radio. :slight_smile:

You’re almost there!

1 Like

Alrighty, thank you very much for all your time and experience. Just taking precautions of removing all nodes and going to look at possibility of hard resetting the USB device before I get this right, otherwise I think I might be hooped, but I can see now that this will all work.

1 Like

Shouldn’t need to hard reset or remove devices (except the locks), the key is only for the secure devices like the locks, everything else will come along for the ride without problems.

1 Like

Ok, so no hard reset option anyways but I did remove all the nodes…I have now tried both usb paths and have no sucess…in the integration GUI it shows:

z wave sigma designs uzb z wave usb adapter (Node:undefined undefined)
and has nothing under Z-Wave network management which is pretty much the same as I was getting every other time I removed the line # s

Gonna try with " config_path: " removed …

Might be the if01 option.

1 Like

sorry i am bad at typing…just edited that last message so that it may make more sense…it seems removing the config_path: line was it…had option finally to start network which it is doing and apparently takes some time

1 Like

Success!!! Got hung up on the network restarting decided to revert back to that other path as I hadnt tried it with the config_path removed, and it finally works with locks!

A million thanks, no way I get this without your assistance!

I have polling interval at 10000 and notice quite a latency compared to the Wink system. What do you suggest for this setting if it is the cause of the latency issue?

Remove the polling interval it’s not needed.

1 Like