Z Wave module configuration help

Hi All

hoping you can help, and this may be a simple one to start with!

I am new to HA and i cannot for the life of me figure out how to change the switch setting for a Fibaro dimmer module. I can find the correct lines in /config/zwcfg_0xc7267d37.xml file, but am not sure what I need to change. I get the default setting is for a mono stable switch switch, but we have Bi stable switches.

Also, if I were to add name and location details between the “” will this change on the main UI?

Hopefully nice and easy for one of you to help out with


What do you mean with “change switch setting”??
Normally you do nothing in the /config/zwcfg_0xc7267d37.xml file ??

If you realy need to change something in this file it will only work when switching of zwave, change the file and switch on zwave again

Thanks for responding.

There is a parameter that can be changed with the fibaro dimmer module that relates to type of switch.

Mono stable(retractive) switch is 0 (set to this by default)
Bi stable(rocker) switch is 1
Three position switch is 2

This was easy to do within the old Fibaro HC I had as everything was accessible and set up. I came over due to the constant issues i faced with that system, and did expect a steep learning curve. I am stumped hiugh as i cant seem to find where to change this parameter. I look in ‘config/zwave_device_config.yaml’ but only 2 of my modules are showing, and they do not have anything that relates to this to change. Do I need to insert a line here? And if so how would it be formatted.

Please let me know if you need me to add the settings text to help out.

As far as I know this kind of setting you need to change at your zwave section:
(The section where you paired your devices)

  • Select the node
  • Go to node configuration options
  • Select the right option
  • change it
  • activate the change

Thanks again.

This worked. To be honest, bit confused at first as for some reason the parameter I need to change(14) does not show up in the 1st dimmer I looked at, hence trying to look elsewhere. Checked on another dimmer and there it was???

Appreciate the help

I’m quite new at HA myself.
This is the first time i’m able to help someone else instead I do need self help :stuck_out_tongue_winking_eye:

Well it is appreciated.

I just seem to be having a nightmare. Getting zwave modules to add is very hit and miss. And now half of them are inactive for some reason. As I have mentioned, I didnt expect a plug and play solution, but this is super frustrating.

I recognize that
I’m busy now for a month and do have everything up and running.
It took me severall nights and huge amount of frustrations.
But now I’m very happy.
If you understand the logic behind HA it will be easier every time.

I’m comming from a Homey, much more userfriendly, but not as strong as HA.
So go on keep trying!!
At the end you will succeed.
Zwave is the most difficult part indeed. pairing devices can be a nightmare.
It is important to set up a good meshnetwork by put powered devices strategic placed everywhere

I do not know your configuration, but I do run HA on a Raspberry Pi4+ 4Gb.
I connected a Zwave USB and Zigbee USB.
My zwave was still giving terrible reaction times. So I added an VeraEdge as hub and splitted up my zwave in 2 networks.
Now it is fast!!!

As programming i use the Node RED add0n for 90%.
I can advice that as programming tool.

Thanks for the response. Nice to know another newbie that got frustrated at the start too. Watching all the tutorials and reading all the literature makes it seem so easy. I knew it wasnt gonna be as easy as the UI in Fibaro, but I thought it worth the shot. I will keep going as I do not give up. But I am sure you will see me on here a fair bit over the next few weeks whilst I get set up properly.

Already put Node-Red add-on on the system, just need to learn that now!!!

Also have Hass-io running on a pi4+. I have a Aeon Labs gen5 zwave stick though. Speed is very good, much faster that the fibaro setup I had, pretty much instant to be fair.

Thanks again for the tips and I hope you stay safe and well in these times

I do use also the Aeon labs gen 5.
I’m quite familair with Node-RED now, so I can help you if you wishes.

By the way you can also connect the Fibaro hub to HA and use that zwave network
see: https://www.home-assistant.io/docs/z-wave/controllers/

what do you mean they are “inactive”?

Do they not work at all or work ok but show as always sleeping/initializing?