Z-Wave Node & Values naming tips?

I’m struggling a bit with my setup.
I’m quite new to this whole home automation thingy. I’ve got Hass running, added an Aeon Z-wave USB stick and ordered a shitload of different Z-Wave products to play with.

The first thing I notice is the Z-Wave node & value names… I started renaming them but got stuck pretty soon in ordering those neatly. How do you guys “name” your nodes/values? Do you use a scheme for it?

I started off with: <room>_<description>

Which resulted in:

  • attic_nightstand_frenck
  • attic_nightstand_daphne

Now I wanted to add some PIR sensors… so that did not make any sense in this scheme.
So I changed to: <room>_<type>_<description>

Which resulted in:

  • attic_switch_nightstand_frenck
  • attic_switch_nightstand_daphne

But then it becomes: livingroom_pir_...?

Problems with this scheme are that these z-wave devices provide more. This PIR sensor for example also provides me LUX information. And I have not even touched the node value namings yet…

Any tips? How do you name your z-wave devices?

I’ve always had issues with setting up “smart” names for things. That is names where part of the name contains some type of intelligence. It never fails when I do that I run into an exception within a week. Going with totally random names doesn’t really work well either. What I’ve ended up doing is kind of a cross between your two approaches. I found that I don’t really care if something is a light (dimmer switch) or a switch (just on/off). I’m more interested in what it controls. So the switch that controls the lights in my office, is simply “office_lights”. The fan is “office_fan”. It doesn’t matter to me that the device that actually controls the fan is a “light (dimmer)” switch. It just matters that the fan is what’s being controlled. My sensors, I just name room_sensor. Then each component of the sensor is exposed as a sensor separately. Using emulated_hue you can assign better names for Alexa to use if you use Alexa. Friendly names show up on the screens. So I have a group for each room in my house, where the friendly names for those devices show up… It works for me. But everyone is different in the way they want things presented to them. So there isn’t really a right or wrong way as long as it works for you.

1 Like

I’ve gone even slacker than both of you… I have ~35 devices and I just pick a name that suits my whim at install and live with it. I don’t feel like it’s too important what they’re named within my code. I add comments to the code if that’s ever an issue. And it’s easy enough to do a “find” (or even a replace if necessary) for a string in all open files in Notepad++

I do use customizations to make common sense displays in the UI. But really, I don’t bother with that much either. I focus on setting things up so that nobody ever uses the UI except, occasionally, myself.

1 Like

Thank you for you input guys!

I know the name doesn’t actually matter that much, but I like thing to be neat :stuck_out_tongue:

I like the way you think @turboc, but that concept causes troubles for me as well. I have serveral z-wave wall mounted switches that have multiple buttons and thus are controlling mixed sources and in some cases even scenes.

I’m just looking for inspiration, anyone else has a method in naming scheme?

I have the exact same problem. I recently (a couple of days ago) switched to hass.io and are now trying to find the best way of adding and naming some z-wave units (lights, switches, energy meter, a lot of temperature measurements, lux, door sensors, fire alarm etc.). They are currently connected to my Vera but that thing is hopefully going to my father later this year when I get everything working here.

On the Vera I started with a naming schema something a long the lines of: type-of-unit_room
Lets say a smoke sensor then got the name: smokesensor_hallway. That would result in: “binary_sensor.smokesensor_hallway” when going to HA for the detection of smoke. For the smoke detector armed state it would be “switch.smokesensor_hallway” and the temp measurement from the same device then got “sensor.smokesensor_temp_hallway”

I’m not super consistent but at least I should be able to tell at the beginning what kind of device I am reffering to (smoke sensor, multisensor, energy meter etc.) what kind of readout I am supposed to expect and where in the house it is, roughly. The bedrooms are only labeled one to three so only I know which bedroom is which at the moment.

I don’t know if I should hang on to this or not…