Z-Wave Range Issues

Hello all!

Home Assistant looks to be one of the top choices for a DIY home automation system. I just started messing around with a few things. I installed a new light fixture with dimmable lights, and got a GE Z-Wave Smart Dimmer. I then got the Aeon Labs Aeotec Z-Wave Z-Stick, Gen5.

I have a server on 24/7 running unRAID. I installed Home-Assistant using docker. While a pain in the backside to try and get the docker to recognize the USB stick, I finally prevailed! But then my issue was, it seemed like my connectivity was basically non-existent. It knew the Z-Wave stick was paired to the dimmer, but had no one to control it.

I decided to carry my server upstairs and give it a try. The server typically sits one floor below, but almost directly below the z-wave dimmer. Without any roofing obstructions, and about 20 feet across the room, it improved, but was still quite flaky.

Does anyone have any experience with Z-Wave and Home-Assistant that could possibly steer me in the right direction?

As an aside, I did test out the stick with HomeGenie. IMO, an inferior interface, but for some reason, was able to connect to the dimmer flawlessly.

In my experience, z-wave is a very flaky. I have the z-stick gen5 and a few multisensors, and I never really got them to work properly with homeassistant. Although they are a bit more expensive, for dimmable lighting, nothing beats LIFX. Hue is another good option, but I personally don’t like having hubs. The one major benefit with Hue is the ability to use the GE Link bulbs, which are substantially cheaper that most other “smart” lights.

Phillips Hue on Amazon
LIFX on Amazon

Have you ever tried Z-Wave with a different piece of software?

I was incredibly surprised with how responsive Home Genie has been betwen my gen5 stick and my GE dimmer. What changes between the software that would cause the hardware to communicate differently?

After finding Home Assistant, I haven’t felt any desire to use another platform, so unfortunately no, I have not used any other software. I imagine the difference might be related to the fact that Home Assistant is all python based, and thus uses the python OZW library, while Home Genie is written in C# whose OZW library might have differences in implementation. I don’t know a lot about how these two systems are written, but that is my best guess.

Interesting. I will have to do a bit more research.

I’m going to attempt to run a Debian VM and see if it’s possibly something with the docker that I’m using. Does anyone else have any ideas as to why the Z-Wave range is so poor?

I have a number of zwave devices (20 or so) and HA has been pretty much rock solid for me. I am using a pi and the Aeon stick.

One thing about zwave is that it is sensitive to routing and moving devices can cause issues. Usually kicking of a network heal will help with this. You can call it as a service from the developer tools.

Kicking of a network heal?

Not sure I understand what this means. I will have to look into this as well.

ZWave networks can be complex beasts. Many of the devices act as repeaters and the network keeps a record of the best return routes for commands. If you move or remove a device this can be disrupted. Healing the network tells the controller to go figure out the new state and can solve intermittent connectivity issues.

Worth a try :slight_smile:

Ah, yes. I follow now. I was thrown off by the wording at first.

I gave it a shot, but no change. I only have the one z-wave device right now, so I don’t know how much that command would impact the routing.

I still need to test home assistant on a different platform other than the docker.

Oh Well, at least I can confirm that its worth persevering, the ZWave does work very well for me.


I’m glad to hear this.

I would really like to get it to work as I feel Home-Assistant has more to offer than most other software.

I’ll report back if I get different results with a different platform.

I have finally succeeded in setting up Home-Assistant on a Debian VM.

I am running this from the exact same location as before where I did not have success.

The results are the same. When events are sent to the node:

2016-05-26 09:48:45.453 Info, Node002, Value::Set - COMMAND_CLASS_SWITCH_MULTILEVEL - Level - 0 - 1 - c
2016-05-26 09:48:45.453 Info, Node002, SwitchMultilevel::Set - Setting to level 99
2016-05-26 09:48:45.454 Detail, Node002, Queuing (Send) SwitchMultilevelCmd_Set (Node=2): 0x01, 0x0a, 0x00, 0x13, 0x02, 0x03, 0x26, 0x01, 0x63, 0x25, 0x0d, 0x8b
2016-05-26 09:48:45.454 Detail, Node002, Queuing (Send) SwitchMultilevelCmd_Get (Node=2): 0x01, 0x09, 0x00, 0x13, 0x02, 0x02, 0x26, 0x02, 0x25, 0x0e, 0xea
2016-05-26 09:48:45.454 Error, Node002, ERROR: Dropping command because node is presumed dead
2016-05-26 09:48:45.454 Detail, Node002, Removing current message
2016-05-26 09:48:45.454 Error, Node002, ERROR: Dropping command because node is presumed dead
2016-05-26 09:48:45.454 Detail, Node002, Removing current message

It seems that there is an issue with the version of OpenZWave running on Python for HA vs OpenZWave on other platforms like HomeGenie.

Any other troubleshooting tips?

Just wanted to follow up on this a few weeks later.

I have still yet to find a solution as to why Home Assistant does such a poor job handling Z-Wave range compared to other Home Automation programs.

I’ve now tried 3 other programs and have succeeded on all 3 programs. Only with Home Assistant does having my gateway and device 15 feet apart separated by a floor/ceiling not work.

Any other thoughts on this?

I’ve been advised through the chat room to try and tinker with the tx power of z-wave on OZWCP.

I have it all set up, but not sure where to go from there.

Does anyone have experience with OZWCP, specifically modifying power and range?

Did you ever get this sorted? As I’ve been experiencing the same issue, with no solution in sight. Did you fix it via OZWCP?

Unfortunately, I did not. I got the library configured and was able to access it through a web browser, but I really have no clue how to modify the tx power of z-wave.

For some reason, Z-Wave is flaky at best on HA. Keep trying in the chat through! I pop in from time to time to ask and occasionally I’ll catch on with someone who will attempt to troubleshoot.

If you do get an answer, be sure to report back to this thread!

Yeah, I get the dead error. But when I move within very close range and reset HA, it works.

Have you had any success?

Update: After following the below directions, specifically the section about adding a Network Key, my Zwave switch lit right up in OZWCP and the Dead node error vanished. I haven’t had any error since, so if you are experience a “presumed dead” error, I would suggest adding a Network Key in the options.xml and see what happens

1 Like