Z-Wave Raspberry board (RaZberry 2) and HassOS

Tags: #<Tag:0x00007f326a42b2a8> #<Tag:0x00007f326a42b1e0>

Hi guys, I just have a question. How can I execute this command: sudo systemctl disable hciuart on RaZberry 2 board when I am running on HassOS? I figured out how I can login to the Hass.io CLI and now I can login to hassio host, but I still can’t execute the command above. Any advise, please?

I haven’t been able to find out how to run this command in HassOS but I don’t think you need to run it on HassOS for the RaZberry board to work.
Just add dtoverlay=pi3-disable-bt in the config.txt and use /dev/ttyAMA0 as the port and it should all work fine - it does for me anyway.

Hi, thanks for the reply. Previously set dtoverlay=pi3-miniuart-bt I have changed to dtoverlay=pi3-disable-bt in the config file, rebooted and in the HA configuration file I have:

zwave:
  usb_path: /dev/ttyAMA0

Unfortunately, it still does not work :frowning:

2020-02-03 09:37:48.038 Always, OpenZwave Version 1.4.3452 Starting Up
2020-02-03 09:38:03.235 Info, Setting Up Provided Network Key for Secure Communications
2020-02-03 09:38:03.235 Warning, Failed - Network Key Not Set
2020-02-03 09:38:03.235 Info, mgr, Added driver for controller /dev/ttyAMA0
2020-02-03 09:38:03.235 Info,   Opening controller /dev/ttyAMA0
2020-02-03 09:38:03.235 Info, Trying to open serial port /dev/ttyAMA0 (attempt 1)
2020-02-03 09:38:03.235 Info, Serial port /dev/ttyAMA0 opened (attempt 1)
2020-02-03 09:38:03.236 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2020-02-03 09:38:03.236 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_MEMORY_GET_ID: 0x01, 0x03, 0x00, 0x20, 0xdc
2020-02-03 09:38:03.236 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_CONTROLLER_CAPABILITIES: 0x01, 0x03, 0x00, 0x05, 0xf9
2020-02-03 09:38:03.236 Detail, contrlr, Queuing (Command) FUNC_ID_SERIAL_API_GET_CAPABILITIES: 0x01, 0x03, 0x00, 0x07, 0xfb
2020-02-03 09:38:03.236 Detail, contrlr, Queuing (Command) FUNC_ID_ZW_GET_SUC_NODE_ID: 0x01, 0x03, 0x00, 0x56, 0xaa
2020-02-03 09:38:03.237 Detail, 
2020-02-03 09:38:03.237 Info, contrlr, Sending (Command) message (Callback ID=0x00, Expected Reply=0x15) - FUNC_ID_ZW_GET_VERSION: 0x01, 0x03, 0x00, 0x15, 0xe9
2020-02-03 09:38:03.239 Detail, contrlr, Notification: DriverFailed

I don’t have the usb_path set in my configuration.yaml. I’m not sure where mine is set.
I booted my Pi3 from the pre-built image and during the configuration I added the ZWave integration and a prompt to add the port that the controller was running on was shown.
When you edited the config.txt did you edit the existing file in /mnt/boot/config.txt and add the line to the end?

Nope, it still doesnt work. Maybe the problem is in RPi 4 or HassOS. I dont know.

So, finally, I sold the board. It was quite uncomfortable to use it without the ability to use Bluetooth module, which is really useful. Even so, thank you for your time.

No problem, I hope you can find a good alternative, I really like z-wave. There is a USB stick version which seems to work well but with all of these things we still seem to have lots of issues that need to be sorted out.

1 Like

Just got a RaZberry2 board for my RPi 3B+:

  1. Plugged it into the very first pins (#1-#10).
  2. Popped out the SD card and used USB reader to access on another computer.
  3. Edited config.txt to add “dtoverlay=pi3-disable-bt”. Ejected.
  4. Put SD card back in RPi and turned it on.
  5. Went to Configuration > Integrations.
  6. Added “Z-Wave”. Set device path to “/dev/ttyAMA0”. HA said everything was good.
  7. Went to Configuration > Z-Wave.
  8. Tried “Test Network” which showed green.

Hope that helps others.
– Brian

2 Likes

Hi Brian, Just letting you know that your instructions worked perfectly for me, thank you very much - I had no idea how to do this and was getting very frustrated. You saved me loads of ‘head scratching’.

Also for anyone migrating from Smartthings it’s really important to delete your zwave devices from your smarttings before trying to add them to a new network - i.e. HA.

I had loads of trouble getting my Razberry to detect devices unless deleted from Smartthings.

Kind regards and thanks for your help.

Pete

Where do you find the file config.txt in HassOS?
If I remember it correctly, the file should be in the boot partition, but I cannot find any boot partition…

Hi!
The config.txt is available in the root if you take out the SD-card and put into another PC. Then you can edit the text file.
Unfortunatly I have been struggling with my Raspberry Pi 3+ and Razberry2 on getting this to work. I have followed instructions above but when I choose “Test Network” it just keeps loading and nothing happends. No green bullet or anything showing up…