Z-wave remotec 120

Hello. I’m using Remotec ZXT-120 to control A/C and got something working incorrect.
I do can:
-dry air
-fan only
I can not set the digits. Default set up 22

degree and if I set 25 - A/C starts working in cool (!) and if I close the window, 25 gets 22 again. It just does not set up. Also, it’s shown that A/C is off when it is on (after making 25 degree)
The second great issue is in temperature sensor inside remotec. It just shows 22 degrees for 3 days, when its not 22 (tried another sensor)
So, need help with setting up digits and sensor.
P.S. on the graph you can see 23 degree, than 22. It’s just because I changed settings and said to remotec to show -1 degree (the compensation)

Found where to change polling intensity, so now can see the temperature

Can u please share how u did it?

Sure. Open “Settings”, “Z-wave”, there you will see “Z-Wave Node Management”, choose "Remotec ZXT-120RU ". Next - you choose in “entities of this node” “sensor.Remotec ZXT-120RU Temp”. And after that you will see polling intensity. Unfortunately, I got asking temp every minute no matter which number i put in polling intensity, may be you will find how to deal with Remotec.