Z-wave stick USB on Synology NAS

I have a DS918+ with Home Assistant installed in a docker. It’s working great. Now add a USB stick for Z-wave (Z-stick 7)

Installed drivers from SynoCli and RobertKlep
Infocenter says CP210x UART Bridge - Silicon Labs

task ROOT made with
/sbin/modprobe usbserial
/sbin/modprobe ftdi_sio
/sbin/modprobe cdc-acm
chmod 777 /dev/ttyUSB0
chmod 777 /dev/ttyACM0

alll done with SSH on a windows machine.

[email protected]:~$ ls /dev/ttyUSB0
So USB is recognized.

Now connecting USB to Home Assistant with --device /dev/ttyUSB0:/dev/ttyUSB0

Ths is what i wrote in SSH

[email protected]:/volume1/docker$ --device /dev/ttyUSB0:/dev/ttyUSB0
-sh: --device: command not found

I must be doing something wrong. Can anyone help me please, i have not installed portainer.

I run on Synology. How do you start that container? Where is it’s configuration?

to be honest, i dunno know what you mean.

/volume1/docker/homeassistant/config this is where the config and container are located.

is there a reason why you are not running a full HAOS VMware install under VMM on your DS918+? I’ve been running it on mine this way for a few years, and it is completely painless other than needing to re-attach the USB port to the VM whenever the Synology reboots.

I should throw in a disclaimer that I’m still running my 918+ on DSM6, and have not tested under DSM7…

The config would be located there. Where do you go to to start and stop the container? Are you using the Synology UI? A docker run command? Do you also have zwavejsui installed? What version of Home Asisstanf?

HASS 2024.3
zwavejsui not installed (i have no ADD-ON in my settings)
i start and stop the container in Synology UI container manager

no reason for docker instead of vmm

Since you can’t use add ons in Docker, you’ll need to install the zwavejsui docker container.


Running docker is more complicated than using a VM, so the alternative to consider is to switch to VM. I run in Docker but I’m also a software engineer.

1 Like

Problem solved. I have reinstalled from scratch. Again in Docker, now i remember why i choose Docker, my system is EXT4 instead of BTFRS.

Thanks guys.

1 Like