Z-wave stopped working lost /dev/ttyACM0

Been running HASSIO since the day it was released and have about 14 nodes on my ZWAVE. Yesterday morning it stopped working, a reload of the HASSIO and the Pi was not responding to anything, no ping, no remote drive, no http. The Aoetec USB Stick Gen 5 continued to blink as normal. I patched into an ethernet port (previously on wireless) and was able to ping the DHCP address, but still no access. Looked like a corrupt USB and HASSIO was not booting.

I rebuilt the HASSIO onto a new Raspberry Pi 3, new flash, a brand new Aoetec USB Stick Gen 5 and different power source. I got HA running with bare minimal config. If I plug in the Aoetoec USB…It blinks and I see the following in my ‘dmesg’:

[63577.450882] usb 1-1.3: new full-speed USB device number 9 using dwc_otg
[63577.554284] usb 1-1.3: New USB device found, idVendor=0658, idProduct=0200
[63577.554304] usb 1-1.3: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[63577.557814] cdc_acm 1-1.3:1.0: ttyACM0: USB ACM device

Bus 001 Device 002: ID 0424:9514
Bus 001 Device 001: ID 1d6b:0002
Bus 001 Device 003: ID 0424:ec00
Bus 001 Device 009: ID 0658:0200

ls /dev/tty*

find . -name ttyA* -print

My show hardware from the GUI give me (which is odd to see /dev/ttyACM0):

When I pull the Aoetec USB Stick out, it all disappears.

Anyone know why I’m net getting anthing in /dev/tty*. BEcause of it not showing up in /dev/tty* my HA startup fails ZWAVE initiation. It working the past, my entry in the configuration.yaml looks like:

usb_path: /dev/ttyACM0
new_entity_ids: true

So it worked and there must have been a /dev/ttyAMCM0.

Any ideas?

thanks in advance.


Seemed to be an erron in the config file.

usb_path: /dev/ttyACM0
new_entity_ids: true

Removing the “new_entity_ids: true” has fixed my issue. My z-wave is working again.

To clarify…When I do a ls /dev, I don’t see /dev/ttyACM0 (I thought I have in the past). That is what was throwing me off.