Z-Wave switch not working in scenes, works via dashboard

One of my z-wave wall switches is misbehaving. The switch in question is a Leviton Z-Wave dimmer with a 3-way aux/remote switch. It responds fine to commands from my Lovelace dashboard if I turn that entity on/off (reliably), but it isn’t working inside of scenes.

I have several scenes in HA that set the level on this switch, and it never gets set. It stays at whatever it was set before the scene was applied – on, off, dim level, all completely unchanged when a scene runs. It worked initially (for a few weeks), but sometime in the last few weeks it stopped. I’ve removed it and re-added it to the scenes – no effect. I’ve never seen this behavior before. All my other light switches (over 30 of them) work fine in their scenes.

This is all on a fairly new install – just built the house and setup a fresh HA instance about 2 months ago. Using Open Z-Wave, whole network is Z-Wave Plus.

Any chance you created or edited the scene from the Lovelace UI?

I’ve been having similar issues with my Zwave GE 14294 Dimmer, and think I may have solved it be re-editing scenes.yml to remove all the excess junk that was added when editing the scene via UI.

I opened this github issue to track my problem - not sure if it may help shed some light on yours.

Yes, I have been using the UI to build scenes ever since I did this new install! Awesome insight, I bet that has something to do with it. I will experiment as soon as I can to see if I can add any info to your GitHub issue.

Well, that was a swing and a miss for my situation. No junk in my scenes.yaml, it’s clean.

I continue to have problems with just this one Z-Wave switch. A scene will activate, and the entity for that switch (on my Lovelace dashboard) shows the state it should be, but the actual switch is not in that state. For example, when my “Night” scene ran last night, the toggle for this switch showed in Lovelace as “off”, but in reality the light was still on.

Toggling the lovelace switch on and then off again makes the light go off. I never have any problem when I manipulate that light directly via the HA UI. Only when it’s in a scene does it (sometimes) not do what it’s supposed to do.

Does your scene use a transition value for the light?

No, it does set a brightness level though (the one in question is “Stair Lights”). However all other light switches like that work fine all the time.

- id: '1606167560804'
  name: Evening
      friendly_name: Bar Cabinets
      supported_features: 0
      state: 'on'
      friendly_name: Family Room Shelves
      supported_features: 0
      state: 'on'
      node_id: 7
      friendly_name: Kitchen Pendants
      supported_features: 33
      state: 'off'
      brightness: 185
      node_id: 5
      friendly_name: Family Room Accent Lights
      supported_features: 33
      state: 'on'
      friendly_name: Kitchen Table
      supported_features: 0
      state: 'on'
      brightness: 129
      node_id: 17
      friendly_name: Stair Lights
      supported_features: 33
      state: 'on'
      brightness: 54
      node_id: 20
      friendly_name: Foyer Lights
      supported_features: 33
      state: 'on'

Are you positive that the light is a zwave plus device? This sounds like a non-zwave plus device.

It’s a Leviton Leviton DZ6HD-1BZ, which is “Zwave Plus Certified”. It’s specifically why I bought them several years ago, because they were one of the first decent ZW Plus dimmers on the market.