Z-Wave switch turning on in HA, but not physically turning on - Help

Hopefully this is the best place to ask - I am getting some odd behaviour in my Fibaro light switches. It is a long standing installation of a mixture of 40ish FGS-223 switches and FGD-212 switches connected to an Aeotec Z-wave dongle.

Been working reliably for 5+ years. I am pretty meticulous with reading the patch notes and applying them and testing them for any breaking changes. The system has been running pretty solidly on my home assistant blue. I am using the Z-Wave JS integration and have been for some time.

My issue is that when I press the light switch - the actual light doesn’t turn on - however it is registering as being turned on inside home assistant. I initially thought it was an issue with the light fixture and had planned on getting an electrician to look at it (it is unlikely to be due to the globes as the fixture has multiple LED globes in it and the chances of both of them going at the same time is remote).

The first instance occurred about two weeks ago - just haven’t got around to fixing it. The weird thing is now another switch is doing exactly the same. When the switch is turned on - the lights don’t work physically - but the switch registers as being turned on in home assistant. This switch controls multiple separate light fixtures - so it isn’t a fixture issue.

The second switch is a trigger for an automation to turn other switches on - and it triggers the rest of the automation fine - and those lights physcially works.

Turning on the switch in HA doesn’t turn on the physical light - they are effectively dead.

I have tried googling for an answer - but they all relate to the opposite issue - where the light works, but doesn’t register in home assistant.

Has anyone else heard of my issue before and can point me in the right direction. There are no error messages related to these switches occuring in HA

The first fixture stopping working wasn’t related to any update of Z-wave - and I have done another update between the first one breaking and the second and things were fine for about a week.

I have copied the logs of the Z-Wave integration for

The switch being manually turned on

The switch being manually turned off

The switch being turned on via HA

The switch being turned off via HA

I can’t see any mention of these switches having a smart bulb mode in its manual

But equally there are a lot of modes in there that I don’t understand

I would love some guidance on where to look to solve this issue - it is really confusing me.

Issues like this can be super frustrating to nail down, I feel your pain. Here are a couple possible suggestions to look into (issues I’ve dealt with before):

  • A device is “jabbering”, or throwing noise out that might be interfering with communication to some of your nodes - could be a bad device or bad connection
  • Your devices are at the edge of the range or are too many hops from the Z-Stick
  • Your network needs healed
  • A device not in your lighting group is having problems and happens to be the one reliable hop to get to the Z-Stick

You mentioned that the light doesn’t go on even when you physically press the button, that sounds like a bad device to me. It could be the Z-Wave thinks everything worked and is then telling HA that it worked, but the actual relay in the switch is broken.

I know it’s remote that multiple switches die at the same time, but I’ve had that happen multiple times on “batch purchases” I’ve made. I remember I had this happen with my Insteon once where four devices all took a dive within a week of each other, as if the hardware just had an expiration date for some bizarre reason.

I’m pretty comfortable with replacing electrical devices myself so it’s always a simple [pain in the butt] to wire in a replacement and take the old device to my “test bench” to see if it’s faulty, but if that’s not an option for you then I’m sure that makes this even more frustrating.

Another thing I’ve dealt with quite a bit is power outages creating problems with my devices. I’ve had power outages kill devices entirely more times than I care to count. Had any recently?

Thanks for your comments

I am pretty happy with the integrity of the z-wave network - one of the devices that died is 2 meters away from the Aeotec Dongle and would definitely be a first hop.

The rest of the z-wave network appears to be working as normal - there is minimal delay for any node activity on the network and otherwise it has been pretty rock solid.

I have healed the network as part of my usual maintenance process.

I am leaning towards the device being broken as well - just really odd that two devices have broken with in a couple of weeks after 5+ years of service.

We do get intermitted black outs - mainly due to fruit bats landing on nearby power lines - but this is more frequent in the warmer months - haven’t really had anything recently.

I do have some spare devices and could get someone to swap them in - I am not happy playing with 240V - so annoyingly I will need to call out an electrician (who usually have no idea about these devices)

I was planning on doing a hard reset of the devices before calling someone out to replace them - as I have little to lose given they are going to be replaced. I assume I need to remove them from home assistant first - what is the best way to do this - via settings / devices / remove failed device?

Well, since the Z-Wave communication seems to be working, you probably can just do a normal exclude to remove the devices - otherwise removing dead devices is also an option, as is just leaving them if you want, they won’t cause problems. The only thing to contend with is that if you don’t remove them right away then rename them so you can name the new entities the same thing so that all your automation and scripts will just resume without a lot of reprogramming.

Jsut 2 cents here. A lot of messages around the forums here to use a good quality usb extension cable between the HA host and the zwave stick.

Another important tip is to never do a total network heal but instead do a per node heal.

Further more yes,crange a signal issue a mainly the culprit with these kind of issues (in my experience)

To me it sounds like the relays have failed in the switches, since when you physically press the switch nothing happens. When you physically press one that works do you hear the relay click?

Electronic devices typically fail during power surges. So it’s possible you got a spike, that wiped them out.

I would try to things:

  1. Cut power to the switches by turning off the breaker. Then turn back on after a minute
  2. Check the device config params and repush.