Z-wave switches end up as "dead" nodes

I’m getting my Raspberry Pi 4 set up on HA, and I’ve got a Zooz S2 ZST10 USB zwave stick. I’ve tried to get two different switches connected and working, but not having any luck. My switches always end up as “dead” nodes.
First I had a Levition DZS15 switch. It was found and added to the zwave network with no problem. But it would never turn the switch on/off correctly, or show it’s status. In the OZW log I saw it being added and then it got some error and ended up dead. This switch had previously worked fine for years with Wink.
Then I had a GE switch sitting in a box, so I pulled out the Leviton and installed the GE. It also added to the network OK, and shows up as “Jasco Products 12722 On/Off Relay Switch”. At first it didn’t quite work right and eventually went dead. So I eventually got it deleted from the system, then added it back, and the node showed up as “undefined device”. Deleted again, then re-added it. Now it’s a Jasco again, and it actually worked for a short time, and I was able to remotely turn the light off and on a few times. But now it is dead again.
Any idea what’s going on? Do I have a configuration error? Bad hardware?
Getting pretty frustrating try to get something to work.

If you only have two mains powered devices are you sure they are close enough to the stick to have a good signal? If the mesh isn’t very strong you could have devices dropping out.

try moving the stick closer to one of the devices or the devices closer together to test if that is the issue.

Yes that was it. I moved the raspberry Pi so it’s 10-12 feet from the switch, and now it works like a champ. Only problem now is I’m getting dirty looks from the wife for leaving the Pi sitting in the hall way. Need to figure out how to get this to work with it sitting back in it’s permanent home in my office. Guess I’ll just have to buy a bunch more z wave devices to build a better mesh
network! :wink:
Thanks for the tip!

But make sure they’re mains powered devices. Battery operated devices won’t contribute anything at all to your mesh.

All, related question here. I’m running a Raspberry Pi 4 with the same zooz S2 ZS10 z-wave stick. I have several Honeywell z-wave smart switches that had been working fine. Within the last month or so, seemingly around the time I updated to 0.117 these nodes go dead intermittently then back to ready. When I look at the properties I see the “neighbors” nodes available so I don’t think it’s a mesh issue and given all was working well up until a month or so ago, I’m inclined to think it’s a different issue.

Has anyone had this issue? I have seen anything about this as a known bug in update, so I’m not sure what my next steps should be to try and resolve.

You can try to revert back to a v116.x and see if it really is related to your HA version or it’s just a coincidence.