Z-Wave Thermostat Capabilities - incorrect setpoint range adjusting


I am having issues setting heating setpoint for z-wave device ZMNKIDx OnOff Thermostat 2 (Home Assistant OS).
Thermostat card for this device allows setting setpoint only in range from 7 °C to 35 °C, but the device operates in range (-25, 80) °C.
I need setting temperature to 50 °C.

I have tried editing config/.storage/core.entity_registry and changing capabilities

"capabilities": {
                    "hvac_modes": [
                    "min_temp": 7,
                    "max_temp": 35

to min_temp: -25 and max_temp: 80, but after reboot this file reverts back to original configuration.
First I have stopped HA server, then I have edited file (ssh connection) and at the end I have rebooted rpi.
After server starts core.entity_registry is reverted.

Are there any other options to adjust thermostat capabilities settings?

Thanks for any help,

Maybe check device settings on physical device.

Potential range may be -25/80 but usually device is set to limit this min/max so user not mistake and set to the extreme.

The HA ui cannot display/change this setting. You must do this on physical device. Only then will HA allow the changes within the allowed range set on physical device.

I cannot change setpoint locally at the device; it can be changed only by sending z-wave command Thermostat Setpoint Set. I have set the desired setpoint by including another z-wave controller to Home Assistant, then I was able to change the setpoint with another z-wave controller. HA correctly displays currently set setpoint (the device reports new setpoint value to HA), but when I make change to setpoint in HA, it can be only made in range 7-35 °C.
Including another z-wave controller to HA to change thermostat setpoint is workaround, but if there is an option to update the device’s capabilities, I would prefer setting setpoint in HA.