Z wave thermostat Honeywell YTH8320ZW1007/U


#1

I just purchased this thermostat and was able to connect it to my system no problem (hassio, zstick, rpi3),
I can see temperature statistic but have no control over the set point. This is the interface i’m given

has anyone come across this issue and been able to control the set point?


#2

Hey did you ever figure out how to control the Honeywell YTH8320ZW1007/U?


#3

No I never got 8t to work. Are you having the same issue?


#4

I can set the cooling set point but right now when my automation kicks it over to heat it will not take a set point to save it’s life which is very frustrating because it kicks on in the middle of the night and just keeps heating setting it’s set point to whatever the current house temp is.


#5

Ok so in an effort to troubleshoot this I removed the device then added it back into HA. I see the following entities under the zwave

image

But no matter what I do with the dry_air (which I’m assuming is linked back to the heat side of the thermostat) nothing changes. I can change the set point in HA all day long to my hearts content but the thermostat will never change its value. I can change the setpoint for AC when the AC is on all I want and it works like a champ but nothing on the heat side of the thermostat. I’m wondering if I should file a bug with the devs about this.


#6

Ok so I was completely wrong with assuming that dry_air is = heat.

So following this reddit

Lead me to go edit the zwcfg file.

There is the supported modes section

<SupportedModes>
                                        <Mode index="0" label="Off" />
                                        <Mode index="1" label="Heat" />
                                        <Mode index="2" label="Cool" />
                                        <Mode index="3" label="Auto" />
                                        <Mode index="5" label="Resume" />
                                        <Mode index="11" label="Heat Econ" />
                                        <Mode index="12" label="Cool Econ" />
                                </SupportedModes>

So then there is a section below that for the command class thermostat setpoint

Because I am a 1 Heat 1 AC system I yanked out all of the other crap in there, and now I have

 <Value type="decimal" genre="user" instance="1" index="2" label="Cooling 1" units="F" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="76.0" />
                                <Value type="decimal" genre="user" instance="1" index="1" label="Heating 1" units="F" read_only="false" write_only="false" verify_changes="false" poll_intensity="0" min="0" max="0" value="68.0" />

Once I did this and started HA back up the thermostat now responds to my changes in HA and reflects it properly. Now will come the test tonight when the outside temp drops low enough for it to kick over to heat mode. I toyed with the idea of setting my thermostat to auto mode vs heat/cool but I really don’t want my AC running in the dead of winter especially once I fire up the woodstove.

NOTE: When editing this file shutdown home-assistant first very very important. If you don’t then your changes will be overwritten.

It appears that this is a bug with OZW and the bug has been opened for a very long time so not sure if its going to be addressed.


#7

Thank you for this solution! I can finally adjust the heater during this winter!

My thermostat is the Honeywell T6 Pro, https://products.z-wavealliance.org/products/2893

Now that I changed the command class to both values for Heating 1 and Cooling 1, this creates 2 entities. Is that how yours turned out?

See my cards below, for a 2-thermostat setup:


#8

Yep that’s how mine is as well.


#9

I found this custom dual thermostat card which combines the entities and it does what I originally expected