Z-Wave USB stick swapping path radomly from ACM0 to ACM1 and back


Have a problem with configuration of Z-Wave stick (Aeotec Z-Wave Gen5). Have Synology box running Docker. When I configure the HA, I point the path to /dev/ttyACM0 and everything works perfectly, but after a random time (cant see any pattern) the path in synology changes to /dev/ttyACM1 so Docker loses the connection and the Z-Wave stops working. The Synology works continuously (it has UPS backup) and the stick is attached permanently so the change is not caused by restarting the Synology or reattaching the stick. Can anyone help ?

Need to add that i tried those solutions:

it seems not to work on Synology + Docker.

Were you able to resolve this ?

Can you make an association by the serialid? Worked well for me in the past.

1 Like


I did not manage to do this. Tried the association, but when put the new device name in the command which creates new container, it fails to add the dongle. I had enough of trying to solve this, because each time the power went out, and the synology restarted, the Zwave network stopped working. I went to the Raspberrry pi with the whole docker configuration - everything is OK since then.

Hmm, very interesting, I actually had this exact problem this week as well, but I thought it was because I was messing around with other USB devices on the Windows 10 server which hosts Virtualbox which hosts Ubuntu which hosts Docker which hosts HASS.IO.

I added and removed a USB memory stick, took out the keyboard USB receiver and thought this is what caused my problem. I never had this problem from simply restarting, did you guys have this issue while doing absolutely nothing with other USB devices on the host server?