Z-wave XML config files

Just to be sure, what was your service call data? Based on the XML, you’d want something like this to change “Speed motor I”:

node_id: <id>
parameter: 7
value: 1
size: 1

Size should be set in this case, otherwise if you leave it out it defaults to 2. If you set the wrong size the device will ignore the command.

Just tried having my breakfast… its no go :/. Tried the service call with a WRGB dimmer I know I can set programmed scene and the call worked so wasn’t syntax etc.

Thanks for your help; I’ve learnt something at least!


Thank you. This was exactly the straight forward info I was missing.

I’m having a similar issue. It seems none of my Zooz devices are recognized, and it may be only because the config file has the hex letters capitalized, whereas the data from the device does not. Can anyone confirm that?

From zwcfg:

<Node id="19" name="" location="" basic="4" generic="17" specific="1" roletype="5" devicetype="1540" nodetype="0" type="Multilevel Power Switch" listening="true" frequentListening="false" beaming="true" routing="true" max_baud_rate="40000" version="4" query_stage="Complete">
		<Manufacturer id="27a" name="Zooz">
			<Product type="a000" id="a008" name="Unknown: type=a000, id=a008" />

Note the id’s from the device are a000, and a008.

From the config:

<MetaDataItem id="A008" name="ZWProductPage" type="A000">https://products.z-wavealliance.org/products/3791</MetaDataItem>
<MetaDataItem id="A008" name="FrequencyName" type="A000">U.S. / Canada / Mexico</MetaDataItem>
<MetaDataItem id="A008" name="Identifier" type="A000">ZEN30</MetaDataItem>

There it seems the id is A008, and type A000.