Z2m /get usage help

Hi Team ,

Trying to use node red to get the current values from the temperature sensor . but i am not able to achieve that , Please let me know how to do it .

i tried injecting temperature json payload to get but it is not working

zigbee2mqtt creates entities in home assistant.

node red should read the entites from home assistant, not from z2m.

Otherwise this isn’t really a home assistant question is it?

1 Like

If node RED subscripted to the same topic than there is no difference if one gets it from HA or by mqtt. Both is in sync if nothing is defective.

For the mqtt question: i think you need to be subscripted to the correct topic and have configured the mqtt server.

Maybe you can provide the config from node red (flow copy via clipboard)?

@HomeTrainee Thanks for you answer , after going through the z2m docs it is not possible to use /get for all devices and my temp devices cannot accept /get so this cannot be done i think . i replaced with HA current state node in my flow .

Hmmm. I would expect, that HA gets that information also by mqtt and transfer it in a HA state. Where else should HA take notice of that?

Anyway, if it is solved, perfectly fine.

If you go to configuration–>integrations–>mqtt–>configure… Listen to #, then publish your topic and see if there is a response

FYI an example of such a device not accepting /get or /set is here