Zanzito - A lightweight bridge between your Android device and your MQTT/home automation system

Any plans to add nfc support? Would be pretty cool to be able to activate things through mqtt with nfc. And not need to use Tasker.

Hi all,

Until version 1.0, Zanzito was using the so-called “in-app purchases” offered by Google to distribute licenses.
It came out that these purchases are not eligible for “Family libraries”, meaning that you cannot share them with your family members.
That is not what I ever intended: I’m sorry I didn’t realize it any sooner.

So, the solution is that now Zanzito has a “licensing app”: an additional app that you have to purchase and download in order to unlock Zanzito fully. This app is family shareable (in countries allowed by Google), so now the problem is solved.
You can still buy, for less, an “in-app” Base license that unlocks all current functionalities but is not upgradeable to full, nor it is shareable with family members.

All owners of a Zanzito license at the current time&date: if you need to share your license with other family members, please write to me and send me your Google order number (GPA-xxxx, I need to keep track of this): I will send you a code to unlock the new licensing app for free.

Please, upgrade to Zanzito 1.1 in any case.

Thanks and, again, I’m sorry for causing troubles.

It would be cool! How would you use it specifically?


To act like a button more or less. Could be used to toggle lights or modes.

1 Like

Any hints on how you got find connected to mqtt? I’m trying and unable to connect.

Just to add to my reply before. I have just added the notify component and it works well. Having set it up now I see that I can just backup/restore my yaml configurations and after a new install of HA it will work as normal (without having to run any additional scripts).

1 Like

If you are trying to install your private FIND server, it’s a bit tricky at the moment… See here

Someone should write a step-by-step tutorial about this :smiley:

Ha as much bumbling and fumbling around as I did to get it working a step by step tutorial would be awesome. So far installing find properly was hands down the most difficult task I’ve tried with my rpi

1 Like

@MrMep It looks very nice, but could I make a small suggestion? I’ve had to uninstall the trial for now as when it is in stopped state it refreshes a notification every minute (along with annoying beep). Maybe disable that?


I just started using Zanzito and it is great but I’m having problem with GPS Accuracy which is very poor. Occasionally gps accuracy goes to 1200 and Zanzito stops updating location for long time. It makes it useless for home automations.

For now I use Owntracks which has really good gps accuracy and Tasker to integrate my mobile phone with Home Assistant but I wanted to switch to Zanzito to use only one application.

Is there any way to increase GPS Accuracy in Zanzito without using High Precision option which drains battery?


Hi, I’ll look into that, but frankly Zanzito relies upon the Android system: it doesn’t have a setting for accuracy. I’d try tweaking the System Preferences: optimal configuration is location active with high precision (I’m talking about System prefs, not Zanzito’s). If you don’t activate “High precision” in Zanzito, the app will not trigger your GPS on so it won’t drain batteries.

Let me know!

Thanks, it shouldn’t beep, I’ll have a look at it.
In the meanwhile, you can simply exit the app when you’re using it: from the main screen, press the"Back" button and confirm exit.


My android system preferences are set to High Precision. I tested both Owntracks and Zanzito apps today in the same time and on the same mobile phone and the results you can see below.
So if both apps use the location of the mobile phone then I’m wondering why Zanzito GPS tracker got stuck and stopped updating position with GPS Accuracy 1200 when in the same time Owntracks was updating the location every few seconds with very precise results.

This is how it looked in Home Assistant. The center of the big circle is position according to Zanzito. The actual position of the mobile phone is near the edge of the big circle and it was sent by Owntracks.

How does the Family license work?
I bought the full version and have the license app on my Android. But Zanzito still shows Buy License on my GF phone

I’m sorry you’re experiencing this kind of problems.
Zanzito registers to system location updates and depends upon them for its own updates. I can see a few scenarios:

  • There’s a bug in Zanzito. It’s certainly possibile, but we’re over 600 installations and this is the first time I see an issue like that, it must be something very sneaky…
  • There’s an issue with your specific model/android version. Could you please send me more details about your device (even in PM) ?
  • Sometimes a specific Android device could manifest problems with Location services. Ideally I would factory reset it, but I guess it’s a painful action to take. I suppose you’ve already tried to reboot your device…

I haven’t specifically looked into that, but Owntracks very likely has a different approach in getting a location fix: so far many users have found Zanzito more reliable, but I’m afraid this is not the case in your situation.

Let me know,

Did you install the license app on your GF’s phone too?

No, how can I do that without purchasing the license again?

Maybe I misunderstood how this Family license work

If you and your GF are in the same family group on the Google Play store, she should be able to download the Zanzito licensing app without having to pay it again. Instead of “Buy” or similar, it should just say “Install” (on the Play store app or website).

Once that is installed, Zanzito will unlock.


Ok, this is a feature that is not available in all countries it seems.

Yeah, I just saw that, I’m sorry. What country are you in?
Send me a PM with your order number (GPA-xxxx), I’ll send you a gift code for your GF.


1 Like