Zehnder Comfoconnect won't reconnect after change of router

HI, can anyone help me reconnect my MVHR? I changed routers and the comfoconnect hub didn’t reconnect automatically. I eventually got it working, so their app now works OK, but I can’t get the HA integration to reconnect. It is reporting “Failed to set-up”. I’ve edited configuraion.yaml with what I believe to be the new IP address. However when I reload the integration it shows the old IP address, not the one in configuraion.yaml, despite restarting HA.
I tried adding a new hub with the new IP address but it says “already configured”.
Each time I try to reload it, it stays in the “initialising” state for a very long time.
I’ve enabled event logging and it says “Timeout while connecting to bridge” which is the old IP address,

In case anyone has the same problem, here’s how I fixed it.
Find file .storage/core.config_enties & copy to another location
Edit IP address of comfoconnect from old to new IP address in the file copy
in terminal run “ha core stop”
copy edited config_entries back to .storage
reboot ha (I had to do this by stopping & then restarting the VM)
Once ha restarted my Zehnder was back working as before.