ZEN32 Scene Controller - Z-Wave JS

If anyone wants to here is an import button which uses the latest version posted by @blhoward2 above, plus some small changes to make it clear which button is for which scene in the automation.

Open your Home Assistant instance and show the blueprint import dialog with a specific blueprint pre-filled.

3 Likes

Thank you @blhoward2 and @MattMattMattMattttMattMattMatt

I’ve been watching this thread so that keep up with any issues and how to resolve them. I had the old blueprint, and saw that it had issues. Updating and removing traces of the old fixed and got everything working as expected.

Is there a way to control the leds on the Zen32? My automation has multiple steps, and I wanted the led to be a different color for each step. Is this feasible?

@triwizard Absolutely there is, I use a separate automation for that because I also want the LEDs updated when the devices are turned on from other sources. This is an example I did using the MQTT method (Keep states in sync between scene controller and Z-Wave switched outlet - #8 by MattMattMattMatt)

However you can do the same thing with the Zwave JS (not MQTT) method. This is an example of a script that I call to turn on or off the led based on if the fan is running:


alias: 'Patio-DR/LR: Sync Scene Switch Lights: Fan'
sequence:
  - choose:
      - conditions:
          - condition: state
            entity_id: fan.patio_ceiling_fan
            state: 'off'
        sequence:
          - service: zwave_js.bulk_set_partial_config_parameters
            target:
              device_id:
                - 6d0726d77c652e5f37071bf7ad0eae42
                - d7617e673d18382dde61419078f4c021
            data:
              parameter: '5'
              value: 2
    default:
      - service: zwave_js.bulk_set_partial_config_parameters
        target:
          device_id:
            - 6d0726d77c652e5f37071bf7ad0eae42
            - d7617e673d18382dde61419078f4c021
        data:
          parameter: '5'
          value: 3
mode: single

Note the “bulk set” is used to set multiple devices (I’m syncing two switches), not sure if it matters or not if you just want to update one or not.

3 Likes

@MattMattMattMatt Thank you

Thank you so much for creating the sub-flow for the ZEN32. It made adding the ZEN32 to my setup super easy!

Commands triggered via the ZEN32 seem to be super slow, and it may well be a coincidence but I noticed this in the Zwave log and am wondering whether it is excessive:

Node 104 is my new (and only) ZEN32. It keeps repeating “treating BasicCC::Set as a report” but I do not know what that means and google was of no help. Something that might be related is Parameter 20 which I enabled. I disabled the relay and use the main button to turn on/off the LIFX bulb powered by this controller. It was my guess that I had to enable parameter 20 in order for Home Assistant to be able to use Scene 5 (big button) to control my LIFX without switching the relay. Is that not so? If not, what is Parameter 20 for?

2021-09-26T02:31:51.406Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:32:04.657Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:32:11.488Z CNTRLR   [Node 042] treating BasicCC::Set as a value event
2021-09-26T02:32:53.612Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:33:06.860Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:33:19.717Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:33:32.969Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:33:44.984Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:33:54.038Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:34:04.443Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:34:20.482Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:34:29.161Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:34:40.126Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:34:53.362Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:35:08.479Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:35:21.716Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:35:30.396Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:35:42.433Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:35:55.668Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:36:30.609Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:36:44.645Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:36:58.671Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:37:27.315Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:37:41.402Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:37:46.461Z CNTRLR « [Node 079] received wakeup notification
2021-09-26T02:37:46.462Z CNTRLR   [Node 079] The node is now awake.
2021-09-26T02:37:47.514Z CNTRLR » [Node 079] Sending node back to sleep...
2021-09-26T02:37:47.566Z CNTRLR   [Node 079] The node is now asleep.
2021-09-26T02:39:58.520Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:40:09.016Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:40:21.593Z CNTRLR « [Node 064] received wakeup notification
2021-09-26T02:40:21.595Z CNTRLR   [Node 064] The node is now awake.
2021-09-26T02:40:22.258Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:40:22.695Z CNTRLR » [Node 064] Sending node back to sleep...
2021-09-26T02:40:22.745Z CNTRLR   [Node 064] The node is now asleep.
2021-09-26T02:40:37.573Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:40:51.665Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:41:00.345Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:41:13.580Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:42:17.966Z CNTRLR « [Node 063] received wakeup notification
2021-09-26T02:42:17.967Z CNTRLR   [Node 063] The node is now awake.
2021-09-26T02:42:18.969Z CNTRLR » [Node 063] Sending node back to sleep...
2021-09-26T02:42:19.034Z CNTRLR   [Node 063] The node is now asleep.
2021-09-26T02:43:12.142Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:43:27.317Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:44:55.927Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:45:09.159Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:45:20.070Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:45:33.295Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:47:53.947Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:48:02.630Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:48:12.999Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:48:25.495Z CNTRLR   [Node 104] treating BasicCC::Set as a report
2021-09-26T02:48:31.638Z CNTRLR « [Node 055] Received updated node info

Is anybody else having issues with this running under the 2021.10 beta? It’s possible one of the many zwave changes has caused an issue.

Howdy,

Just installed this thing and the blueprint. I have a scene that activates when “pressed once” on scene button 1. however the way the button is set up by default, it acts as a on/off button and only activates the scene button gets turned on which means that it has be pressed twice at times (if the button was already on, i have to press it once to turn it off and again to turn on to make the function work).

Is this as intended or did i setup something wrong? I assumed the scene buttons were buttons and not on/off switches.

Thanks in advance!

@bmac6996 mine do not work that way. I did go to the advanced config and change the lights so they don’t toggle when pressed, not sure if that change effects the z-wave messaging though. You can look at what is happening in Home Assistant by going Developer Tools → Events → “Listen to events” type in “zwave_js_value_notification” then hit subscribe. Hit your physical button and you should see the event information, if it is behaving differently 1 press to the next these messages should have a difference.

For example here is what mine looks like when I press a button:

{
    "event_type": "zwave_js_value_notification",
    "data": {
        "domain": "zwave_js",
        "node_id": 3,
        "home_id": 3638336493,
        "endpoint": 0,
        "device_id": "cfe0eadddc32e367654ef0c5425260bd",
        "command_class": 91,
        "command_class_name": "Central Scene",
        "label": "Scene 004",
        "property": "scene",
        "property_name": "scene",
        "property_key": "004",
        "property_key_name": "004",
        "value": "KeyPressed",
        "value_raw": 0
    },
    "origin": "LOCAL",
    "time_fired": "2021-11-15T15:05:41.120930+00:00",
    "context": {
        "id": "178ca299225342b96bde76692dfc6553",
        "parent_id": null,
        "user_id": null
    }
}
1 Like

Thanks for this subflow! Made setting this up really easy for me.

Anyone else recently having issues with the blueprint? I’ve tried to delete and reimport but having the same issue.

Problem: When I add some scenes to my blueprint my automations stop working. When I restart HA the Automations tab under Configurations disappears and I get a notification that says

The following integrations and platforms could not be set up:

When I look in the logs I see ‘errors during the setup of component automation’ and ‘errors for setup of dependencies of default_config. Setup failed for dependencies: automation’

I didn’t have any issues until the last couple of days

1 Like

Same issue here.

I just added this blueprint yesterday and its my first one. I had the same issue as @jdsthatguy and @rockmonkey4004 It was giving me errors when looking at it in VSC, I used the import link here in post 21 ZEN32 Scene Controller - Z-Wave JS - #21 by MattMattMattMatt. In VSU it didn’t like the {} after action: When looking it would show

action: {} Incorrect type. Expected “null”

I just removed each of the “{}” after action on each of the scenes in the blueprint then saved and it works for me now. So those lines now look like:

action:

Hopefully this helps others running into the same problem. This Blueprint is Great! now to find all the actions I want it to do :smiley:

2 Likes

@csmart30 Thanks for looking into it, I updated my gist to remove the brackets

Open your Home Assistant instance and show the blueprint import dialog with a specific blueprint pre-filled.

1 Like

@tsukraw Again thank you for sharing your Zen32 node! I was wondering whether you figured out a way to use the device name rather than a node id so that I don’t have to go update the node id every time it changes (rarely, I know, but I’ve had to do it a few times now just for firmware updates and other issues).

I love this blueprint, it’s exactly what I needed and works perfectly. I’m not much of a programmer and do most things through the UI, so I just wanted to say thanks for putting this together and sharing!

I use tts for audio feedback. That way google will tell my family what is happening. For example, “the big button has been pressed and held, so I am turning off the room lights”, or “the upper right button has been pressed twice, so I am turning on the lamps”.

1 Like

If a solution like this is available for the Zen34 Wireless remote switch can you point me to it?
If not would it be possible for someone to adjust this one to work with the Zen34? I tried to do it, but I unfortunately do not have the skills.

Thanks that saved my bacon, wish i had noticed your message 2 hours earlier mind you :slight_smile:

any chance you can update your post? this version you posted no longer works, i wasted an hour before i realized :slight_smile: it needs the {} after action: removing… i know there are updated ones lower down, but i am sure somone else like me wont read the whole post…