ZHA and Tradfri bulbs

Does anyone have issues with ZHA integration and tradfri bulbs losing connections with your network? I want to say I can issue 2 or 3 commands to the bulb through the app, site, or an automation and then after that it is just unresponsive for a bit. I looked in the logs and saw this:

Logger: bellows.zigbee.application
Source: /usr/local/lib/python3.8/site-packages/bellows/zigbee/application.py:644
First occurred: January 26, 2021, 5:55:16 PM (85 occurrences)
Last logged: 7:44:19 AM

Watchdog heartbeat timeout:

This happened 85 times over the last day or so. I don’t know if they are related or not but it is really making my head hurt.

I am using a sonoff zigbee bridge with tasmota firmware 9.1.0 (I just hit the update button this morning and will see if that helps). I have the latest firmware for ZHA, and I don’t think my ikea bulbs are updated to the newest.

So I guess it could be tasmota needing to be updated or Ikea Bulbs needing to be updated (How do I do that??)

Any help would be greatly appreciated!

Hi there,

I use a Zigate and have had zero issues.

I do however have issues with devices that have a Sonoff brand on it :slight_smile:

My Sonoff zigbee motion sensors have a limited reach. Perhaps this is also the case with your hub?

You might have a look at this thread and specifically this answer:

I tried out what you suggested and it seems to be working! I can turn the lights off multiple times without any drops. so it is either updating tasmota, ota for tradfri, or source routing that did the trick.

thanks again!

1 Like

tech that works! what a concept!

Super glad to hear the hard work of all the folks that are contributing to zigbee and ZHA are moving folks forward to home automation that stays within your home!

Good hunting and Happy New Year!

I am curious to see if you see any OTA firmware upgrades successfully completing on ZHA. I have a Ikea switch that ZHA seems to trying to upgrade the firmware via OTA but it seems to continues to fail.

I have set this log level in configuration.yaml and an watching it :

    zigpy.ota: debug

I’ll take a look at my switch, but from what I remember is that the switch turns off or sleeps unless it is pressed so I think you might have to keep pressing the button or at least press it once to get the update to start?

Well that seems painful and slow. I hope ZHA at least remembers what updates are available and when you wake up the switch via a press, ZHA starts to work.

Well my light didn’t respond last night or this morning. I am going to try some more options that were found in this thread Some lightbulbs drop off (tradfri)

I’ll see if that works. If not I will have to convert my 2 or 3 ikea things to something else.

Well that sux! bummer. Yes definitely communicate with
Marko Rakar
I have not heard an update from him, but you both are navigating some similar territory.

It still works (I had single bulb randomly go on, but eventually it came back on its own, without reconfiguration or re-pairing).

Whole system is still on close observation and my next move is to start doing scenes and automations. But, so far so good, solutions and ideas offered in the avove mentioned thread proved to be helpful and likely (as I wrote, still monitoring before I pronounce problem closed) also solved my problem :).

1 Like