ZHA can not remove device

I have latest version od HA/ZHA and recently added Sonoff zigbee bridge (tasmotized to use it with ZHA).

I have managed to add my sensors except for Xiaomi button (WXJG01LM), according to the compatibility list it should work ok.

When I start discovery, latest HA/ZHA discovers my button, I got message “starting interview”, but whatever I do and regardless of the pressing of the button to keep it alive it simply does not pair with my bridge.

I can see it in devices:

But no other information is visible and I do not see how can I remove it from the list or do anything else with it (I have searched the forum and found very vague reference to zha.remove but I do not see how to use it). At some point I got the device there, but nothing else was visible (other devices have some properties exposed), I clicked “remove” and from that point on I only have screen as seen above.

Any ideas what to do?

p.s. I guess that when I got my device paired without entities that is actually correct setup (and should filter device and event), but I can not repeat that anymore

You can use zha.remove in the Developer Tools. You’ll need to pass the ieee argument but that should remove the device from the controller.

1 Like

is there some guide on how to actually use zha.remove (screenshot, link to wiki or anything), my google search does not return anything solid on how to actually use it

thank you :slight_smile:

Sure… Here is mine:

You can get the ieee from the device info:

4 Likes

thanks, this clarified removal process, but what happens when in description of your device you do not have all of this data?

see my first screenshot, it shows a device, but not identifying info

when I try to pair, I get to this screen, but that is that, after pairing process completes (likely times out), I still get my first window, device is shown, but no identifying addresses or characteristics

Capture

so, i could not find solution to deleting my device, but in other thread I have found a way to finish interview with my xiaomi button

solution is here:

solution is that we need to keep pressing pairing button in order to finish interview (not to button itself, but pairing button/hole)

Just wanted to drop a thank you in here, I couldn’t find a way to do this but eventually my googling brought me to your answer, which worked first time. Much appreciated.

ZHA is very difficult to work with. There is no way to remove a device via the Integration, as the “Remove” link is missing. I tried it via services, but that did not work (at least not via brandont screenshot method). It keeps adding a “data” parameter.

I want to move all my SONOFF devices from ZHA, because they just keep failing. Nightmare to work with in ZHA. When I use Zigbee2mqtt all my other SONOFF devices work flawlessly. ZHA always has issues. Not sure what the problem is, but it seems to be buggy.

I figured out how to remove devices in ZHA in 2024 (Brandons method will not work!!)

See screenshot:

Not sure why this keeps changing??? Also, why on earth does the integration not have a remove link? Is that so difficult to do? Having to do this via script everytime is kind a ridiculous. Given the fact that so many buttons keep loosing connections, one has to manually remove devices every month multiple times.

Ummm.

1 Like

My hue light got stuck in the middle of initialisation. Now it sits in ZHA as some generic zigbee device. No “remove” option like on the screenshot above, zha.remove doesn’t do anything either…
Might have to completely reset ZHA

I too have a device that failed during interview but shows up in ZHA. But, no Zigbee info to get the ieee, no remove button, no entities. Not sure how to get rid of it.