Zha can't connect to freshly installed RaspBee II on RPi 4B / RaspBee II seems not available

Hey, late for the show.

I’m still not sure why you didn’t just follow my detailed step-2-step guide in the initial post: Zha can't connect to freshly installed RaspBee II on RPi 4B / RaspBee II seems not available
It says exactly what you now did :wink:

And yes, you don’t need the enable_uart=1 part. That alone does nothing, if you don’t connect actively to the miniUART. You only need the dtoverlay.
Even, iirc, the miniUART is automatically activated by dtoverlay=disable-bt.

If you however still need Bluetooth, you need to remove the dtoverlay again and add another one plus one more line:


The first (new) line switches BT to the miniUART. So you will effectively have both active:

  • The UART on the GPIO, accessing your Raspbee II
  • Bluetooth on the miniUART

The 2nd line was sth about the CPU speed or clock. I can’t really remember anymore. It is required, if you want BT on the miniUART. You can find details in the links @dbrunt posted when helping me, which I also added to my initial post :slight_smile:

But glad it works now :slight_smile:

1 Like

Sometimes it’s tough to see the trees for the forest! I remember my first go-round with this getting the RaZberry to be seen. It was my first ever venture with a Pi and I was confused as hell! I think it took me days to figure it out!! I had 20+ years experience with SCO UNIX and only a wee bit of Linux…

Yeah, same for me :slight_smile: No RPi experience until this and then trying to get that to work…
I just wanted to point out the step-2-step guide is already up there :wink:

I actually did find your post, but there are a LOT of posts offering advice and I honestly tried them all. When I couldn’t mount the disk on my Macbook Pro, I went another route to get to that partition and got it working. I figured a short, succinct post that explained how I got it working with the Raspbee II and a Pi 3 B+ would be helpful. I can’t speak to how it works for a Pi 4.

It was very satisfying throwing the Ikea hub in the trash. It was not a fun experience constantly losing access to it through the app, having things drop off of it for no reason, etc. Hopefully it was the hub and not the Ikea bulbs and switches. Even so, now that I have both z-wave and zigbee going, I have a lot of choices to replace those should they so much as look at me funny.

I’ve not tried Ikea bulbs but I did try ERIA Tunable White but they would randomly turn on for no reason. Sent them back to Amazon and got Sengled Element Plus White Ambiance and they are working great. They don’t route Zigbee but they also do not randomly turn on which is great. I saw some new brand of Zigbee bulb at Home Depot. I am going to try one…

Can’t find the boot partition? Me either.

You may have to mount the /boot partition manually. I did. It shows up in gparted, but wouldn’t automount on my Ubuntu 20.10 desktop.

  1. mkdir boot
  2. sudo mount /dev/sdb1 boot
  3. sudo gedit boot/config.txt
  4. add dtoverlay=disable-bt to the end of the file.
  5. sudo umount boot
  6. rm -rf boot

Thank you all, particularly @ezcGman, for the information here, which allowed me to finally piece together how to get it to work.

I’d bought a raspbee (version 1) years ago, never got it to work, and gone with SmartThings. Now that I’m fed up with network outages breaking my light switches (think “discussions” with my wife when we’ve been unable to turn off the bedroom light at bedtime without unplugging a hot bulb or flicking the breaker on all the upstairs lights, including the kids’ rooms), I’ve decided to dust it off and do it the HA way. I was struggling for a long time, trying to figure out where I was going wrong, before I found this thread.

For the sake of the search engines for anyone trying to debug as I was, I was getting error messages in the deConz addon (yes, I realise it’s strictly off-topic as I’ve not tried ZHA, but most of what follows is common) log such as:

  • “raspbee Failed to get a valid bridge ID. Discovery aborted” and
  • “device disconnected reason: 4, index: 0”
    When I was trying to set up the deConz Integration I was getting:
  • “No radio hardware connected to deCONZ”
    in the pop-up message.

I thought I’d share the details of how I did it in case someone else is having the same problems, as it was slightly different from some of the suggestions above and it may be helpful. I learned a few partial answers along the way before finding this thread(!) and also wanted to minimise taking my SD card out, so I went with the SSH option for editing config.txt. This therefore might help others who are trying to enable SSH to the host and/or edit config.txt through that route.

I’m running HASSOS V4.15, Home Assistant Core V0.117.6, Supervisor V2020.11.0 on an RPi4 with a Raspbee version 1. I’m using a PC running Ubuntu, so a few of the following will need to be done a bit differently if running Win/Mac.

  1. Starting point was HASSOS set up (though this would presumably work with other Home Assistant installation channels), the deConz addon installed but not working.
  2. configuration option in the deConz addon must include: device: /dev/ttyAMA0 for a raspbee (different for a conbee)
  3. Each of the network ports set to defaults on the deConz add on configuration page
  4. Enabled SSH access to the host:
    a. Created USB drive with partition labelled CONFIG. For completeness, using gparted on the PC I created a new partition table, then created a single small (~100mb) FAT32 partition and labelled it CONFIG.
    b. Created an SSH keygen pair on the PC, using the ssh-keygen terminal command.
    c. Copied the id_rsa.pub file (the public key) into the root of the CONFIG partition on the USB drive and renamed the file authorized_keys
    d. put the USB drive in the RPi and either rebooted or told Home Assistant (or rather supervisor) to import the details.
  5. SSH into the Pi: on the Ubuntu pc, the command was ssh root@[local IP address] -p 22222
  6. if it connects, type login
  7. cd /mnt/boot - this takes you to the boot partition of the HassOS Pi. ls should show that “config.txt” is here.

Here we run into a little niggle, because HassOS doesn’t have a great selection of terminal text editors and I’m not sure whether or how you can install more. I did, however, find that it has … vi. :man_facepalming: So…

  1. vi config.txt
    a. down arrow key to get to the bottom
    b. o allows you to add new text in a row below
    c. type dtoverlay=disable-bt then <ESC> (or you can do the miniuart-bt version plus force_turbo=1 on another line, as described above)
    d. :x to save and get out of there
  2. exit to get out of the SSH
  3. probably best to restart the Pi. In HassOS, the cleanest way is, I think, from Supervisor>System
  4. At that point, with discovery: enabled, the Integration came up automatically and was set up successfully.
    Phew. Fingers crossed…

Hope this helps (at least for me next time I need to rebuild the system!:grinning:)

1 Like

Great post, thanks!

One point I don’t get (and I also saw others do it): Why don’t you just edit the config.txt on the SD card? :slight_smile: Just stop the RPi, get the SD card out, stick it into your PC, edit the config.txt and that’s it. So as I described it in my post above.

Here’s also the official docs link on how to get access to HAs host system: https://developers.home-assistant.io/docs/operating-system/debugging/#ssh-access-to-the-host

Thanks @ezcGman. Mainly because my pi is the garage, which I have to go outside to access and it’s November in Scotland! :grinning:

(Slightly) more seriously, I wanted to enable SSH access to be able to make other changes in future without that trudge to the garage. It’s actually only marginally more hassle than editing config.txt on the card … and I’ve messed around with mine by trying both the miniuart-bt and disable-bt varieties so so far I’ve saved 1 trudge. :slight_smile: (and I think it’s best to minimise unplugging the SD card as much as possible).

Thanks for the link to the official guide. That’s (partly) what I was working to for step 4 above; I thought it was worth bringing it together sequentially, as you have to visit t least one other page (e.g. to generate the rsa keys) and it took me a couple of attempts to figure out what exactly needed to be done.

Anyway, hopefully it might help someone to pull together the threads that others, such as yourself, have found.

Best wishes,


1 Like

Say no more than “November in Scotland” :laughing:

Firstly thank you for all the great information. It led, ultimately, to a successful installation of my Raspee module. Only a few things were a bit different. My SDRAM card was not readable via my Mac mini nor my Lenovo Yoga or another Raspberr Pi. SSH was not working. So I had to get at the config.txt document via the HA console, monitor, keyboard and all that mess. Once it booted up I found my Raspee at ttyS0.

Home that helps someone.

By the way when I placed the SD card in my other Raspberry PI it was a little different in that while it claimed it could not read the drive because of disk block error of some kind it mounted various HASSIO directories as drives. Just no access to anything from the root up. However the RPi for Home Assistant boots up fine from the SD card everytime.

Hey jsut in case people are having issues with this on ubuntu raspberry pi or others…I finally got it to work with OP’s suggestions and one other step.

Mount the memory card on a windows or mac computer.

In the config file add →

“dtoverlay=pi3-disable-bt” ** note - did this on raspberry pi 4

now open cmdline.txt and delete…

“console=serial0” ← or anything similiar to serial… DO NOT DELETE TTY

Reboot and its been working with my raspberry4 and docker using only ZHA

edit: i believe this is due to the fact that raspi-config even if installed does not actually update the config files and cmdline files correctly

I have tried this solution. And i tried a couple of months ago as well just adding the #dt-overlay=disable-bt as well but still nothing.

My file is now like this:

Uncomment this to enable GPI0 support for RPI-RF-MOD/HM-MOD-RPI-PCB


What am I doing wrong here?
Regards Freddy.

The ‘# in front of was wrong and I also deleted the extra ones so now its working and looking like this’


The # is the symbol to make a comment in yaml files; they are ignored by the parser

Yes so i understood, but took me a while. I am used to // if I will comment anything. But thanks anyway.

Sorry to revive an old thread but this was the most complete walk-through I was able to find and wanted to chime in case anyone else was making the same mistake I was.

I made the edits on config.txt as noted above, but kept getting an error when trying to connect to the Raspbee II while adding an integration using ZHA. Turned out my issue was that I still had my deConz add-on started. As soon as I turned off the add-on (Settings | Add-ons | deConz → “Stop” & disable “Start on Boot” option), I was able to connect ZHA to my Raspbee II and I was in business.

Thanks to everyone who took the time to document their steps taken. It took me to what wound up being 99% of the way, with the remaining 1% being my own foolishness. Hope this helps someone else!

1 Like

Hey, I’ve tried all what you mentioned for my config on rpi4b. I’ve purchased RaspbeeII module and somehow I’ve managed to make it work. Configured also Zigbee Home assistant and detected my ikea switches. But all my Xiaomi BLE thermo&humidity sensor stopped working as they were configured with BT (flashed firm).

The only place I’ve found for something related is this one: Integrate RaspBee 2 into Home Assistant - Robin Bühler

And this is my current config:

#Config for RaspbeeII

Nothing I do seems to fix the BT. If I set it to disable also the ZHA stops working too. I can have now all zigbee integration working but then all my BT one is not.

Does it work to buy these usb dongles?

Thanks, Regards.

I also struggled with this problem and found this:

here it says that for RaspBee II you need to set port speed = 38400
additionaly, i’ve set data flow control = hardware

plus, of course, an entry in /mnt/boot/config.txt:

# uncomment to enable primary UART console

# RaspBee II Config
1 Like