Zha disable device router for one device

Hey i have a lot of problem with a zigbee led stripe rgbww. This is functional as a router but it does its job very bad so i want to disable it as a router and use it only as an EndDevice. How is this possible. because last night all my connected zigged devices that goes through the LED Stripe goes offline because this fucking China think don’t want to live. I am talking about: ZB-CL01 from eWeLight
Does anyone have the same problem? and how to solve it or does anyone know how to disable routing for only one device?

I don’t think you can disable it. However, Zigbee should sort this stuff out for itself - if one device isn’t working, messages should be routed round it. Adding a couple more routers nearby so that there are alternative pathways may do the trick.


I had a couple of problematic routers in my mesh before. You can’t disable routing for a particular device in a Zigbee mesh, but you can add more routers near it and hope they get the end devices (as @Stiltjack said), but there is no guarantee of that. Your best bet is to get rid of the device and replace it with something better.

Sucks to say that as it’s e-waste and a waste of money, but unfortunately, that’s the world we live in.


You can definitely not disable routing on a Zigbee Router device in ZHA or in Zigbee2MQTT, not in any other Zigbee implementation that I am aware of.

Indeed, all you can do is follow best practices which act as a preventive measure to avoid issues, see: