ZHA Errors with HUSBZB-1

I have a Raspberry Pi 3 with Hassbian on 0.52.0. I installed the GoControl HUSBZB-1 tonight to connect some Sengled Element Zigbee LED bulbs.

I added -

  usb_path: /dev/ttyUSB1
  database_path: /home/homeassistant/.homeassistant/zigbee.db

to my configuration.yaml. I was then able to call the permit service and connect the bulbs. I can toggle the lights on and off and dim via home assistant. But it doesn’t seem to remember their states, and I get this error anytime I toggle a state -

2017-08-29 20:44:10 WARNING (MainThread) [bellows.zigbee.application] Unexpected message send notification
2017-08-29 20:44:12 WARNING (MainThread) [bellows.zigbee.zcl] Data remains after deserializing ZCL frame
2017-08-29 20:44:12 WARNING (MainThread) [bellows.zigbee.zcl] [0xd3c8:1:0x0019] No handler for cluster command 1

I saw someone had success with changing the config file to -

  usb_path: /dev/ttyUSB1
  database_path: zigbee.db

but I tried and got an error that it couldn’t find the database.

Any ideas or help? Thanks!

1 Like

I have 5 of the Sengled bulbs which work great.
But I have log full of the same messages.
I have just been ignoring them because everything works great.

For your state issue I have set the initial state in my configuration.yaml file

#      icon: mdi:ceiling-light
      friendly_name: 'Bedroom'
      initial_state: 'on'

@jhall0712 An issue was created for the error messages but hasn’t been addressed yet - > https://github.com/home-assistant/home-assistant/issues/8822

I have not tried those lights yet but from what I have seen they are suppose to work.

I think I see that error when a light is physically turned off and then back on. No event is fired when the light turns off, but as soon as it comes back on I see those errors.

My log is filled with them every 2 - 3 minutes from last night…

@wakeskate I meant to ask. So are your Sengled bulbs not actually reporting their states either then if you have to tell HA to make the intial state be ‘on’?

Thanks. Hopefully it will be addressed soon. It is throwing that error in my log every 2-3 minutes!

Was this issue ever addressed? I’m getting the same problem now. My error log is full of “Updating zha sensor took longer than the scheduled update interval 0:00:30” and “Unexpected message send notification” that pops up 2-3 times a minute. I’m unable to control any zigbee devices as well. If I reset HA, the bulbs work again for a bit, but then this same error pops up. I just tried deleting my zigbee.db and re-added all the bulbs after a factory reset. Hopefully that does the trick. Anyone else encounter this?