Zha_event not showing for most of devices - Sonoff ZB Bridge running on ZHA

In the end I get 2 types of error:

1st example from the log whenever I press the on button of a particular switch or a toggle button of a particular remote:

Ignoring message (b'013501') on cluster 6: unknown endpoint or cluster id: 1

2nd example with a different error message for another switch:

[0x9280:1:0x0006] ZCL deserialize: <ZCLHeader frame_control=<FrameControl frame_type=CLUSTER_COMMAND manufacturer_specific=False is_reply=False disable_default_response=False> manufacturer=None tsn=26 command_id=0>
[0x9280:1:0x0006] ZCL request 0x0000: []
[0x9280:1:0x0006] No handler for cluster command 0

This seems perhaps different than my issue as my devices seem to still stay connected - although I’ve been having a few devices drop off the network (end devices) but no issue re-pairing.

  1. How long was evrythingrunning fine for before this happened?

  2. Did all the devices stop sending events at once, and if so, did you upgrade around then?

  3. What happens if you power cycle the Sonoff (I think these are wifi arent they?)

  4. Any chance your 2.4ghz wifi has changed channels recently? Could this be the case - https://www.metageek.com/training/resources/zigbee-wifi-coexistence.html

I’ll keep you updated if I can work anything out. At the moment I think my issue might be more of a device handling issue arising from some change.

Mine seem to be paired as well. But I get no zha_event output

  1. I set everything up and it worked ok. After that I left home and updated a few things incl. HA Core while away
  2. Some devices still work. I have 4 switches that work decent. Meaning they work, but I sometimes detect that I press a few times and nothing outputs on zha_event. The rest of the devices don’t send anything as events and throw the error I mentioned when pressing the buttons and checking the logs in the ZHA configuration.
  3. Same thing. Meaning nothing changes.
  4. Like I said, some devices work ok, incl the light bulbs. I only have problems with ~ half of the devices that communicate via events. Other half works ok

I would like to emphasize that the devices that don’t send events are seen in the logs of ZHA configuration while pressing the buttons. But it throws errors like this Ignoring message (b'013501') on cluster 6: unknown endpoint or cluster id: 1

I am curious what you get in the logs when pressing buttons on the devices that don’t send events

This is an ‘on’ then 'of’f on one of the Nue scene switches (no relay) by looking at the log whilst attempting to join:


0x0000:zdo] ZDO request ZDOCmd.Mgmt_Permit_Joining_req: [60, <Bool.false: 0>]
[0x0000](EZSP): started initialization
[0x0000:ZDO](EZSP): 'async_initialize' stage succeeded
[0x0000](EZSP): power source: Mains
[0x0000](EZSP): completed initialization
[0x9ec4:1:0x0006] ZCL deserialize: <ZCLHeader frame_control=<FrameControl frame_type=GLOBAL_COMMAND manufacturer_specific=False is_reply=False disable_default_response=False> manufacturer=None tsn=10 command_id=Command.Read_Attributes>
[0x9ec4:1:0x0006] ZCL request 0x0000: [[0]]
[0x9ec4:1:0x0006] ZCL deserialize: <ZCLHeader frame_control=<FrameControl frame_type=CLUSTER_COMMAND manufacturer_specific=False is_reply=False disable_default_response=False> manufacturer=None tsn=11 command_id=1>
[0x9ec4:1:0x0006] ZCL request 0x0001: []
[0x9ec4:1:0x0006] No handler for cluster command 1
[0x9ec4:1:0x0006] ZCL deserialize: <ZCLHeader frame_control=<FrameControl frame_type=GLOBAL_COMMAND manufacturer_specific=False is_reply=False disable_default_response=False> manufacturer=None tsn=12 command_id=Command.Read_Attributes>
[0x9ec4:1:0x0006] ZCL request 0x0000: [[0]]
[0x9ec4:1:0x0006] ZCL deserialize: <ZCLHeader frame_control=<FrameControl frame_type=CLUSTER_COMMAND manufacturer_specific=False is_reply=False disable_default_response=False> manufacturer=None tsn=13 command_id=0>
[0x9ec4:1:0x0006] ZCL request 0x0000: []
[0x9ec4:1:0x0006] No handler for cluster command 0
[0x7c99:1:0x0019] ZCL deserialize: <ZCLHeader frame_control=<FrameControl frame_type=CLUSTER_COMMAND manufacturer_specific=False is_reply=False disable_default_response=False> manufacturer=None tsn=143 command_id=1>
[0x7c99:1:0x0019] ZCL request 0x0001: [0, 4478, 0, 1, None]
[0x7c99:1:0x0019] OTA query_next_image handler for 'FeiBit FNB56-ZSW03LX2.0': field_control=0, manufacture_id=4478, image_type=0, current_file_version=1, hardware_version=None
[0x7c99:1:0x0019] No OTA image is available

And this via event listener (developer tools -> events, enter * under listen to events,hit start listening):

{
    "event_type": "zha_event",
    "data": {
        "device_ieee": "00:12:4b:00:1b:a3:ac:ce",
        "unique_id": "00:12:4b:00:1b:a3:ac:ce:1:0x0006",
        "endpoint_id": 1,
        "cluster_id": 6,
        "command": "on",
        "args": []
    },
    "origin": "LOCAL",
    "time_fired": "2020-09-29T10:41:15.812826+00:00",
    "context": {
        "id": "4d02e0a9024011ebac0a4fc279cf8920",
        "parent_id": null,
        "user_id": null
    }
}

Might be worth checking this out: Sonoff zigbee button SNZB-01 issue (only in cloud mode)

Also, it might be helpful for you to add Zigzag and/or ZHA Map to your HA so you can see where the links are, just in case it shows a mesh problem perhaps?

Interesting!! Thank you for the recommendations.

I just installed ZHA_MAP and it is messy. I have a few questions. Maybe you have time to answer if you have any experience with the map and zigbee in general.

  1. Any idea how I can change the linkage? For example Led Color Bulb Remote Control (red icon on the right) to be directly connected to Lab Bulb RGB (yellow icon on the left next to the blue one)?

  2. Any idea how I can change the name of the devices? For example for the yellow icon down below called Ikea of Sweden TRADFRI bulb E27 CWS opal 600lm, I actually changed the entity name to Livingroom Color Bulb in Configuration -> Entities. But I have no clue how to change the Device name so it could also be reflected here.

  3. I read here that line color represent different LQIs. I thought that meant something physical, but when I moved the icons around, the color of the lines changed as well. What gives?

Any path with a LQI over 192 is shown as green, LQI 129-192 is shown as yellow, and anything 128 and lower is shown as red.

  1. Most of the connected devices like the Remote Controls to the right do not work. Meaning they do not send anything in zha_event. And thus we get back to the main theme of this post. So any solutions here are appreciated as well.

Thank you so much!!

You can’t. Zigbee searches it’s own mesh. The best you can do is repair close to the desired router (bulb in this case), but normal Zigbee devices can reroute dynamically. Aqara devices are the big exception : they tend to stick to the device they were originally paired with.

I paired all my devices with the Sonoff ZB Bridge. Maybe I should have paired a remote control with the Light Bulb I wanted to use it with? To start on the right foot?

It is worth trying.

1 Like

Thank you, Francis! Any idea about the rest of the questions?

Unfortunately, no. Your mesh looks nice however.

  1. No, I think generally linkage is based on strongest signal. There is new options in ZHA however that say “Link devices to this device” or similar…

  2. Try the Customize menu perhaps

  3. Hmm … my lines done change colour. I wouldn’t worry too much - I think it is a snapshot at the time (try ZHA list for more details)

  4. I have heard that too many devices connected to the Coordinator can cause problems. Otherwise, everything looks ok. If something is not connected via line such as a temp sensor, it can be that it’s just asleep (in my experience anyway).

Mine is also messy…

1 Like

I would not call that messy. The more interconnected lines you have between mains powered devices, the better the mesh.

1 Like

What version of ZHA_Map are you people running? My map doesn’t look like the ones above.

Jim

Thank you, guys!!

@jimford, I just installed ZHA_MAP so the last version.

My version is 0.3.1. Maybe I haven’t got the ‘visualisation card’ properly installed.
Jim

Take a look at ‘ZigZag’ Jim :wink:

1 Like

I fixed my problems by deleting the zigbee.db file and then uninstalling and reinstalling the ZHA integration. And then adding each device again :expressionless:

@Lee_au:
I’ve done a search for ‘ZigZag’ but only came up with this, which shows no mention of a map:

Do you have a link, please?
Jim