ZHA failed to start, one possible error

A few weeks ago I noticed my IKEA ZigBee devices acting up and I read Some posts here it could be / was due to updates.
So I thought better disable the updates before more of my devices fails.

So I did this:

And figured that would work.

Today I needed to reboot and I checked the configuration and it said OK.
Which is technically correct.
But after the reboot today ZHA failed to start and I tried to reload ZHA, restart HA, migrate the network, I even bought a new conbee.
After about an hour I remembered my #.

Apparently adding a # there makes it not boot correctly.

In case you also do the same mistake.

What would be the correct Yaml to turn off the updates?
Is it?

ota: []

I’d just comment out the entire zha section. You were only using those lines to add support for the ikea updates, so when you commented out the only part which was used, you made the lines above it redundant and prone to issues.

Removing the zha section won’t break your install - it will just use the default config. Had a look at my config and there’s no zha line anywhere to be found, despite running it for over 3 years.

Just for reference, there have been reports of HA OS version 12.3 breaking the ZHA integration. Not sure this applies to you, but worth checking into.

I’m still on 12.1.