ZHA - Grouping Covers

Currently, creating ZHA groups with covers does not result in a new HA entity (the documentation does not mention that groups are available for covers, though it does still allow a user to create one).

The workaround for this is to create a group in HA, but this means that a call to close all the blinds in a group causes a.command to be sent for each blind. I have 6 IKEA blinds in one group, and I find that there is often one blind that doesn’t close, or one blind that lags behind. If ZHA groups worked with covers, that would mean just one single command to open/close the group.

I am using Deconz and struggling with the same… I was thinking to switch to ZHA would solve this but seems it doesn’t then…

How does people solve or workaround this? We can’t be the only ones wanting to use grouped covers in HA.

1 Like

My workaround is to just send the command twice (one 60 seconds after the first) and hope that they all close. It works the vast majority of the time, but it’s definitely not ideal. And that only works for timed automations…using the remote or voice commands is a headache.

Any progress on this? I’ve got one Ikea blind and one Third Reality blind and I can only even select the Ikea blind as an option in the group. The TR blind won’t even show up even though they are almost identical and both paired to ZHA. This may be more of an issue with the TR driver? I set both covers to device type Blinds. All this would be irrelevant if the group won’t work anyways. Will it work with Z2M? I’m not too far invested to not make the switch.

I am also experiencing this. I can group covers, but no entity is created to control them.

Is this on a roadmap at all? It would be extremally useful to have this option for other entitles not just lights and switches…
This is available on Z2M and is one of the features I miss since moving to ZHA.

2 Likes

Running in to the same issue in the 2023.03. Can add blinds to a zha group but no entity seems to be created. Either creating the entity or throwing an error of some sort when trying to create a group would both be preferable to the current behaviour.

Same issue. Any solution?

Same issue. I ended up creating a helper instead: Link to Helpers – My Home Assistant

The cover grouping in ZHA is still not working for me, no entity created.

Any update on this matter?