ZHA Groups useless in scenes?

Hi all! First post for me on this great forum so hope I’m doing well.
I’m running into the issue that when I want to add a zha group in a scene, the Conbee zigbee coordinator is added containing all other zha groups. Which renders the function useless.
Is there a way of still using scenes and not having to revert back to scripts?

Would be nice if ZHA groups ar not connected to the coordinator or better, that you could simply add single entities (without the device) to scenes this would also be nice for led-strips with multiple segments for example.

1 Like

Having the exact same problem. Adding a single entity group adds the entire coordinator with all groups and renders scene concept useless.

I however don’t remember this problem from a few months back - if memory don’t elude me I have had groups in scenes before - must have.

I’ve been running into this myself, and the solution for me was after creating the scene to go in and edit the scenes.yaml manually, removing the groups I didn’t want from each scene. They still show up in the UI like the screenshot above, but triggering the scene no longer impacts all groups, just the one(s) you care about.

I had to install the SSH add-on in order to get in and get to the scenes.yaml, and I’d love to figure out a way for this to just not happen anymore, but it is technically possible to work around it :+1:

1 Like

Pleeeeeeeeease fix this. Switched from Deconz to ZHA but this is really a deal breaker.

I was hoping that the new groups stuff in 2022.4 would finally fix this, but looks like this was not addressed :frowning:

You’re talking the latest big update @ericreiche? I haven’t tried it yet, I will over this weekend probably, sucks to hear this is still an issue :frowning:

At least it should be easier to build groups though, so that’s something.

Yes exactly. You still can’t add ZHA groups to scenes.

Maybe we need to add a feature request to have the possibility to add entities separately to scenes.
When you look in the scene editor, you see that when you add an entity it will add the device if available. This is something I do not understand the logic behind…


This is for sure unfortunate :confused:

Huzzah, found a solution!! If you enable “advanced mode” on your user profile you then have the option to add entities, as opposed to entire devices, in the scenes UI editor.

1 Like

this does not help, You can add entities, but after saving the scne it’s back to devices which include all groups, and hence is unusable

I stopped using scenes alltogether. I don’t like I have to place my entire house in full darkness to edit a “go to bed” scene. I don’t like the fact that too many unneeded properties are set. I just create a script to explicitly set the things I want to set. As a bonus, I can add things like conditional statements or input helpers that scenes won’t allow either.

What scenes are good for is saving the current state of things to return to it later, but I did not find much use for that at this time.

1 Like