ZHA: how to set on_off_control on motion sensor

I migrated from Deconz to ZHA and now my motion sensor have a timeout for more then 3 minutes.
I found in the logs some timer:

motion_ego On With Timed Off event was fired with parameters: {'on_off_control': 1, 'on_time': 1800, 'off_wait_time': 0}

I saw, there is a option in the device: “Manage Zigbee Device” where I can set attributes like this.
I set this to 30 but the “on_time” is still 1800.
Do you know how I can adjust these timers?

nobody with the same problem?

Hi, @netzbus I think i run into the same issue. I’ve got a Hue motion sensor which I’ve added via ZHA integration with a conbee 2 Stick. When motion is detected, the on value is triggered with the parameter on_time 3000. This makes the motion sensor useless for any automation below 5 minutes.

Here you can see an example, motion sensor detects motion on 15:35, sends with the parameter
{'on_off_control': 0, 'on_time': 3000, 'off_wait_time': 0}
then 5 minutes later you can see the reset. Problem is if I want to create an automation which turns the light off after 3 minutes it won’t work.

Reading the value of the motion sensor it returns null. As it is null it shouldn’t be a problem on the motion sensor side. Parameter is sent from the integration/HA.

I can live with a time of 2 minutes, but 5 minutes lower the possible automation’s in my mind. Any idea to fix this issue?

Did you get to the bottom of this? I’m in the same position and would also like to alter the default 3 min timeout on the motion detection.


did someone of you solve this problem? I also moved to ZHA from deconz and have the same problem. In my case i made a full new network setup and connected every device one by one.

Same Problem Here.

I have this too, 300s is too long. Does anyone know how to change the default timeout of the motion on ZHA?

1 Like

Any update on this? I have a weird behaviour using multiple Philips Hue motion sensors (SML001).

Some sensors react more or less instantaneously and some have the 300 seconds timeout. Both after being reset and included in a new Home Assistant installation. Comparing the “diagnostics” both seem to have the same settings.

1 Like

I had the same issue with ZHA + Conbee USB Stick and found a workaround by the hint of ZHA - Use Philips Hue SML001 as Occupancy Sensor for light control. I set o_to_u_delay to 5 seconds and then occupancy started reacting very quickly.

See screenshot: Imgur: The magic of the Internet

But now, motion detection doesn’t work at all. For now, I built my automation over occupancy but hopefully I can figure out how to use motion sensor entity properly. (I’m not sure difference between motion and occupancy for this device though)

See screenshot: https://imgur.com/ruyKSth

(Sorry, I couldn’t embed images since this is my first message here)

1 Like

If anyone comes across this issue with the on_time parameter set to 3000 when the event is being fired, just delete the device from HA and re-add it and it will revert back to the standard 15 seconds.

The same problem with more PIRs from two manufacturers. Time ON is 1 minute. Any idea for short this time?