ZHA - Ikea Symfonisk sound controller GEN2 (the square one)

Have any one had any problems with this controller? I bought 2 of them and both just after being connected to HA started toggling my Aqara plugs without any configuration whatsoever.

If there is nothing in HA saying it’s toggling them (so no automation) then they might have some how binded to the plugs ?!?
Not sure how that would have happened, i’ve only got 2 zigbee devices and the skyconnect device which are all less then a few weeks old so i have no real knowledge if you can bind like that…

I’ve checked everything I possible can, every log, events, even opened db file and couldn’t find anything that binds controller with plug :frowning:

Unpair/default both devices ? (Again just guessing)
Also look at doing a firmware update to the devices ? Zha does have some guides on how to do that on home assistant.

Works perfect for me, thank you!

I have had similar behaviour with some of my IKEA bulbs and switches.
Some just were bound as soon as I onboarded them onto my SkyConnect stick. The issue was resolved by selecting the device and manually unbinding them. That can all be done inside the SkyConnect integration. Click on the device you want to unbind (it think you need to select the steering device, but don’t nail me down on that), then go into the deeper settings. In the “Binding” section you can select the device you want to unbind from the dropdown and click “unbind”.
My integration is broken right now, so I can’t give you a precise step by step guide, but thats the rough way to do it.
Hope this helps!

This worked good for me

But it needed some tweaking, the next/prev track buttons weren’t functioning and after looking at the zha_event I found a couple of things in the blueprint that compounded and resulted in the behaviour.

  • The dots condition is evaluated before the next/prev track condition
  • The conditions for the dots were the same as the next/prev track in the blueprint

This meant that any press of the next/prev track would evaluate as the dead end dots condition.

All I had to do was move the next/prev track condition above the dots one.

Hope this helps, easy fix.

I made some tweaks to fix my above problem and also added some volume control that worked a bit better. The media_player_volume.up and down do weird things, so I took the volume control from the script Eric Kreuwels had for the gen 1 remote.

Volume still seems to be buggy but I cant quite figure out why.


I’ve been watching the ZHA posts and hopefully they will have the Gen 2 firmware 1 and 2 added soon. I will will update the blueprint to include the dots.
Hopefully it might help with the volume issues as well. It might be worth doing the fireware as it adds press and hold commands (i think)

I removed the single and double dots option. I shall change it once they push the working changes ZHA has for the dots.

Seems that not only we’re having issues with the new buttons.

I think the adde the support in the new beta for the shortcut dots. Maybe now this can work

1 Like

Hey James, I just added this controller and I do not get any error messages. Could it be that the problems with the buttons have been resolved?

Would be nice to see them added to the blueprint (I have no idea how to write one myself).

Hi Ben,

I wanted to add the dot buttons as well, so I did some tweaking myself a few weeks ago and got it working. Wanted to finish it up today and came across your comment, so I decided to upload it.

You can find it here: ZHA - Ikea Symfonisk sound controller GEN2 (the square one) with dot-button support for new firmware.

Should have full control for the two dot-buttons with options for single, double and long press. You do need the newer firmware, but I also link to a resource on how to update if necessary.

Hope this helps!

1 Like

Hey there, thank you so much. Somehow the controller was updated automatically and the buttons were not responding, but after removing the remote, taking out the batteries and pairing it again, now it works perfectly.

Now let’s make up some nice things to assign to the buttons.

Good jobs ppl

I had exactly the same issue. Also Aqara plugs.
What I did is:

  1. Deleted the device from HA
  2. Took a piece of aluminium foil
  3. Got the switch as close to the coordinator stick as possible, wrap them in foil
  4. Re-added the device

The reason for the foil it that I have 2 more Aqara plugs right near the coordinator and the HA server is plugged in one of them. I did not want to get it triggered, so at least some more RF protection.
Now they’re not triggering anything by themselves.

Now I’ve moved the switch to it’s permanent place and I need to observe if this random switching behaviour returns after some time when or not, when switch connects thought that other Aqara plug it was originally switching on and off.

Weird stuff

I connected the remote correctly to Zigbee2mqtt. But when I try to add the device in the blueprint automation, it could not find the device…

The blueprint is hardcoded to look for it on zwave its self, so it won’t work without modding.

Thanks! Did not read ‘ZHA’. I already found the Z2M version :slight_smile:

1 Like