ZHA - Lutron Aurora Dimmer Blueprint - toggle button press

The button press should toggle to the previous brightness, and that is what is happening for me. Are you sure you are using this blueprint and not the original?

Thank you for your reply.
Yes, I am using this blueprint.
There might be something else wrong. I noticed that the automation toggles (checked the trace), but the light turns on to full brightness, even though it was at 50% before. When I toggle the bulb via dev tools, it works as expected.
I will have to do some more troubleshooting.

Awesome Blueprint. For those of us using a nortek stick where the button presses are unreliable, how would one make the blueprint turn off the light if you continue to dim the light?

Mine actually does turn completely off by dimming. Maybe you could write an automation if the light is less than 10% then turn off?

Thankyou for this! Works very well.

One query: the dimming is very “jerky”, i.e seems to have about 7 “dimming values” that it snaps too. Whereas If I adjust the dimming via a home assistant Light Card, it’s very smooth.

Do you know what I could do to make the dimming smooth with the Lutron Dimmer? Is it possible to achieve that?

1 Like

What is the sensitivity set to? That adjusts how often HA sends the commands to the light. The higher the sensitivity the more chatty the automation is. I have mine set to 3 and it seems to work fine. I hope this is helpful.

The blueprint works well for dimming a light group, but the button press doesn’t do anything. I can turn the lights on by turning the dimmer dial, but cannot turn them off.

I have mostly the same situation as Brooklyn_Sid, though the toggle off has worked once or twice. Looking at the trace though I’m not seeing anything wrong.

If you are using the Norek zigbee/ zwave adapter I can confirm that these Hue switch do not work with them (and exhibit the behavior you are seeing: unreliability on the button press) unfortunately the notification is not getting to HA. I solved this by switching to a conbee stick for zigbee, I am still using the Nortek for zwave.

Hope this is helpful

Unfortunately (or fortunately I guess) I just installed the SkyConnect. Signal seems great so far with all of my zigbee devices (a mix of Hue and Ikea).

I am using the Sonoff Zigbee Stick 3 like @catboxer and maybe others. I am able to pair the dimmer to my stick no problem. However, when I push the button while looking at ZHA events in the logger I see nothing coming through. (I did pair and unpair several times with the same result) I haven’t yet tried the blueprint because I thought maybe I would need to be getting something showing when button pushed knob turned, but maybe not? Anyone know if I need to see something before the blueprint can work?

Meanwhile, I also saw on the ZHA github something called a “Quirk” which seems to be a translator for “non-standard” message content into expected HomeAssistant message content instead. That seemed promising, and there was even already an Aurora Dimmer “Quirk”. But it was a different model of the same product name. Anyone tried ZHA Quirks?

Thanks all!

Honestly, these dials are just poorly-made. They’re by far the least-reliable devices I’ve attempted to set up, only working maybe 20% of the time. I’m returning them and just replacing them with child locks and a separate button. It’s a bummer, because this type of hardware really would be perfect, but as it stands they just don’t communicate over zigbee reliably (even when in the same room as the skyconnect stick, which is on a few-foot USB extension).


Mine work excellent. Loved the first one so much, I brought a second one. I do wish they came with their own mount, so you didn’t have to install it on a light switch.

So, for the second one, I 3d printed a little stand for it, and just stuck it on the side of the fridge, as that is the best location for a lightswitch without specific layout.

I love the hardware. Super reliable. Sorry you had issues. FYI I’m using a Sonoff 3.0 Zigbee USB dongle, in case that helps.

I have one dimmer paired via Philips Hue integration, and the second connected directly to HA.

Mine’s working again, I just use the blueprint and no other automation is required to make it work. I agree they’re a bit flakey on dimming, but 95% of time they turn on/off on click.

I ended up digging one of my old Phlips Hue lights out and just doing a direct connect. That’s the main thing I was trying to do anyway, keep someone from switching off my computer when they flip that wall switch. Gave up getting this to work with HASS and the Sonoff Zigbee stick (but didn’t try the blueprint, was just easier to use the Hue)

Yea I still cannot get the on/off button presses to work. Dimming works great. Which doesn’t make sense really

1 Like

Hi @richlee91, I have managed to get this setup successfully but like other reports when I dim my Aurora Switch, it stutters. I see this similar issue was resolved for the Zigbee2MQTT Lutron Aurora blueprint (see here: Zigbee2MQTT Lutron Aurora Dimmer Control - #32 by ipomea) and was wondering if we can get a similar fix.

This is the last thing remaining to migrate me fully to Sonoff stick :slight_smile:

I also have the same issue, but see it was resolved with another blueprint here: Zigbee2MQTT Lutron Aurora Dimmer Control - #32 by ipomea

To top up, regardless of what I set the sensitivity to, I still get the same problem.

I just installed today and I’m seeing a random issue with the button press and slow dimmer response no matter the sensitivity setting.