ZHA - Lutron Aurora Dimmer Blueprint - toggle button press

Based on the great work of bjpetit. Thank you!

This updated blueprint changes the action of the button press. So now if you press the Aurora button it toggles the light. If you turn the knob it adjusts the light to the dimmers brightness. In my case I wanted this so if another automation adjusts the status of the light it will not be out of sync with the dimmer.

1 Like

Great idea! Is this possible with Zigbee2mqtt too? I don’t see anything like that presstype variable in the MQTT payload… I wonder if Zigbee2mqtt is missing something that ZHA supports for this device.

What coordinator are you using? Cannot get this to work with my SonOff 3.0 USB.

I’m using the Conbee II. It SHOULD work with any Zigbee stick but I know the Aurora does not work with the Nortek stick (or at least it does not reliably) It should work on the Sonoff stick. Are you using ZHA or another Zigbee integration? (This only works with ZHA) What do the events look like coming in from the stick?

I don’t use Zibebee2mqtt, so I can’t comment. Maybe someone else can assist.

Yep, ZHA Sonoff running Z-Stack 3.30+ (build 20211217). At this point I would settle for even the button to toggle the lights on/off. It does have a button as part of the device attribute, but physically pressing the dimmer button doesn’t register an event in HA.

So I removed and re-added the Lutron and this is now working for me! Thank you. Hopefully it stays connected.

Create Blueprint! Is there any way to turn the light on to the previous brightness, instead of full brightness?

Thank you!

The button press should toggle to the previous brightness, and that is what is happening for me. Are you sure you are using this blueprint and not the original?

Thank you for your reply.
Yes, I am using this blueprint.
There might be something else wrong. I noticed that the automation toggles (checked the trace), but the light turns on to full brightness, even though it was at 50% before. When I toggle the bulb via dev tools, it works as expected.
I will have to do some more troubleshooting.

Awesome Blueprint. For those of us using a nortek stick where the button presses are unreliable, how would one make the blueprint turn off the light if you continue to dim the light?

Mine actually does turn completely off by dimming. Maybe you could write an automation if the light is less than 10% then turn off?

Thankyou for this! Works very well.

One query: the dimming is very “jerky”, i.e seems to have about 7 “dimming values” that it snaps too. Whereas If I adjust the dimming via a home assistant Light Card, it’s very smooth.

Do you know what I could do to make the dimming smooth with the Lutron Dimmer? Is it possible to achieve that?

What is the sensitivity set to? That adjusts how often HA sends the commands to the light. The higher the sensitivity the more chatty the automation is. I have mine set to 3 and it seems to work fine. I hope this is helpful.

The blueprint works well for dimming a light group, but the button press doesn’t do anything. I can turn the lights on by turning the dimmer dial, but cannot turn them off.

I have mostly the same situation as Brooklyn_Sid, though the toggle off has worked once or twice. Looking at the trace though I’m not seeing anything wrong.

If you are using the Norek zigbee/ zwave adapter I can confirm that these Hue switch do not work with them (and exhibit the behavior you are seeing: unreliability on the button press) unfortunately the notification is not getting to HA. I solved this by switching to a conbee stick for zigbee, I am still using the Nortek for zwave.

Hope this is helpful

Unfortunately (or fortunately I guess) I just installed the SkyConnect. Signal seems great so far with all of my zigbee devices (a mix of Hue and Ikea).

I am using the Sonoff Zigbee Stick 3 like @catboxer and maybe others. I am able to pair the dimmer to my stick no problem. However, when I push the button while looking at ZHA events in the logger I see nothing coming through. (I did pair and unpair several times with the same result) I haven’t yet tried the blueprint because I thought maybe I would need to be getting something showing when button pushed knob turned, but maybe not? Anyone know if I need to see something before the blueprint can work?

Meanwhile, I also saw on the ZHA github something called a “Quirk” which seems to be a translator for “non-standard” message content into expected HomeAssistant message content instead. That seemed promising, and there was even already an Aurora Dimmer “Quirk”. But it was a different model of the same product name. Anyone tried ZHA Quirks?

Thanks all!

Honestly, these dials are just poorly-made. They’re by far the least-reliable devices I’ve attempted to set up, only working maybe 20% of the time. I’m returning them and just replacing them with child locks and a separate button. It’s a bummer, because this type of hardware really would be perfect, but as it stands they just don’t communicate over zigbee reliably (even when in the same room as the skyconnect stick, which is on a few-foot USB extension).