ZHA - Lutron Aurora Dimmer Blueprint - toggle button press

Based on the great work of bjpetit. Thank you!

This updated blueprint changes the action of the button press. So now if you press the Aurora button it toggles the light. If you turn the knob it adjusts the light to the dimmers brightness. In my case I wanted this so if another automation adjusts the status of the light it will not be out of sync with the dimmer.

Great idea! Is this possible with Zigbee2mqtt too? I don’t see anything like that presstype variable in the MQTT payload… I wonder if Zigbee2mqtt is missing something that ZHA supports for this device.

What coordinator are you using? Cannot get this to work with my SonOff 3.0 USB.

I’m using the Conbee II. It SHOULD work with any Zigbee stick but I know the Aurora does not work with the Nortek stick (or at least it does not reliably) It should work on the Sonoff stick. Are you using ZHA or another Zigbee integration? (This only works with ZHA) What do the events look like coming in from the stick?

I don’t use Zibebee2mqtt, so I can’t comment. Maybe someone else can assist.

Yep, ZHA Sonoff running Z-Stack 3.30+ (build 20211217). At this point I would settle for even the button to toggle the lights on/off. It does have a button as part of the device attribute, but physically pressing the dimmer button doesn’t register an event in HA.

So I removed and re-added the Lutron and this is now working for me! Thank you. Hopefully it stays connected.

Hi!
Create Blueprint! Is there any way to turn the light on to the previous brightness, instead of full brightness?

Thank you!

The button press should toggle to the previous brightness, and that is what is happening for me. Are you sure you are using this blueprint and not the original?

Thank you for your reply.
Yes, I am using this blueprint.
There might be something else wrong. I noticed that the automation toggles (checked the trace), but the light turns on to full brightness, even though it was at 50% before. When I toggle the bulb via dev tools, it works as expected.
I will have to do some more troubleshooting.

Awesome Blueprint. For those of us using a nortek stick where the button presses are unreliable, how would one make the blueprint turn off the light if you continue to dim the light?

Mine actually does turn completely off by dimming. Maybe you could write an automation if the light is less than 10% then turn off?

Thankyou for this! Works very well.

One query: the dimming is very “jerky”, i.e seems to have about 7 “dimming values” that it snaps too. Whereas If I adjust the dimming via a home assistant Light Card, it’s very smooth.

Do you know what I could do to make the dimming smooth with the Lutron Dimmer? Is it possible to achieve that?

What is the sensitivity set to? That adjusts how often HA sends the commands to the light. The higher the sensitivity the more chatty the automation is. I have mine set to 3 and it seems to work fine. I hope this is helpful.

The blueprint works well for dimming a light group, but the button press doesn’t do anything. I can turn the lights on by turning the dimmer dial, but cannot turn them off.