ZHA - Moes Universal IR Remote


I’m fairly new to HA but have have managed to integrate zigbee lights, sockets and blinds etc in ZHA.

I have purchased Moes smart IR remote control (zigbee) and have added it to ZHA.

My issue is that it only allows monitoring of battery and control on/off for the device. Has anyone been able to use the IR function to learn?

Thanks in advance.



Hi Rob, welcome to the community.

I am guessing that you need to watch for ZHA events. Have any services been created? (check dev tool)

1 Like

Is that Moes UFO-R11, also sold as Aubess ZXZIR-02, which both are rebranded Tuya TS1201, then post your information and debug logs to these device feature request issue(s) and pull request(s) in the ZHA Device Handlers repository:

Also read section about how ZHA Device Handlers (a.k.a. quirks) are needed for unsupported devices:


“How to add support for new and unsupported devices” under “Knowing which devices are supported”:



@RobertZ Hi Rob, did you ever get this to work. I’m interested in the device but would like upfront if it works.

Hi, I have this device and it works with Zigbee2MQTT. A youtuber named BeardedTinker made a video of how to integrate this with HA.


This device is still not supported in ZHA (2023.12.3). There is a github request for a new quirk: zha-device-handlers/zhaquirks/tuya/ts1201.py at 3f859d693523db36f0e5bf8b0248ea15ba78e4db · ferehcarb/zha-device-handlers · GitHub however, being a complete noob, I’m am unable to get the quirk to function. Other people do report as to have it working.

I had to add a new MODELS_INFO id to the quirk ~

    ("_TZ3290_7v1k4vufotpowp9z", "TS1201"),
    ("_TZ3290_acv1iuslxi3shaaj", "TS1201"),
    ("_TZ3290_ot6ewjvmejq5ekhl", "TS1201"),    # <<-- THIS ONE

But I’m still getting errors in the logs I don’t yet understand ~

023-12-20 08:03:00.750 DEBUG (MainThread) [zigpy.application] Device is initialized
2023-12-20 08:03:00.752 DEBUG (MainThread) [zigpy.quirks.registry] Checking quirks for _TZ3290_ot6ewjvmejq5ekhl TS1201 (34:25:b4:ff:fe:4c:43:6b)
2023-12-20 08:03:00.752 DEBUG (MainThread) [zigpy.quirks.registry] Considering <class ‘ts1201.ZosungIRBlaster_ZS06’>
2023-12-20 08:03:00.752 DEBUG (MainThread) [zigpy.quirks.registry] Fail because endpoint list mismatch: {1, 242} {1}

and then a few lines later …

2023-12-20 08:03:00.781 DEBUG (MainThread) [zigpy.appdb] Error handling ‘_save_attribute’ event with (34:25:b4:ff:fe:4c:43:6b, 1, 0, 4, ‘_TZ3290_ot6ewjvmejq5ekhl’, datetime.datetime(2023, 12, 19, 21, 3, 0, 749628, tzinfo=datetime.timezone.utc)) params: FOREIGN KEY constraint failed

Can anyone offer any help here?

In ZHA with quirk I have that

But I don’t know what to do after that!

With @emydomo prompting, I looked at the device control - and indeed, with the quirk, the Moe’s [UFO-R11] IR Blaster was functioning OK.

I found further instructions on this blog: Tuya Zigbee IR Blaster Remote ZS06 Review - SmartHomeScene

Using this I was able to record IR signals from my existing remote control.

I still don’t understand what those log messages mean.

I now need to make a “Remote Control Look-alike” panel to play them back in a manner non-technical normies can recognise.

1 Like

Hi @q98
Were you able to create the “Remote Control Look-alike” panel?
I managed to capture and test the on/off IR signals for my A/C and was trying to write a script to have it work in HA but I’m very new at this and I’m kind of lost.

No, I got distracted and forgot about it.

The TV I wanted to use it with, an Aldi Bahun TV, had a broken remote … so I couldn’t duplicate the IR signals anyway. I bought a new remote, but it didn’t work, etc. etc.

This works for me (ZHA), but it’s a very simple case - just turning on a striplight:

alias: "[Lighting] Counter lights on"
  - service: zha.issue_zigbee_cluster_command
      cluster_type: in
      endpoint_id: 1
      command: 2
      ieee: b4:3a:31:ff:fe:f5:3c:34
      command_type: server
        code: >-
      cluster_id: 57348
mode: single
icon: mdi:led-strip-variant
1 Like

Hello, I made the adaptation, put it in, created the folder and put the file inside it, which was passed through the website, through git, but I don’t know what to do now, how can I configure it to copy the signals. Would you help me? I am a beginner. Thank you very much.

Sorry, I haven’t had time to look at this again. But I learned how to capture remote IR codes from the linked documents.

Do you mean you’ve installed the quirk? The device info page should look like this:

So here’s my configuration file that I imported, the Python script there, and there is also the about the entity that is not the same as yours.

Have you restarted HA?

Yes, I did a hard reset on Home Assistant. Should I re-adopt the device to make the changes or not? Or is it another problem?

Yes, try re-pairing.

I tried to repair the device again, but it didn’t work. It didn’t show the part that it had to show.

Take out the batteries for a minute or two first, then re-pair?