ZHA Network Map Question

Tags: #<Tag:0x00007fc41ef352c0>

Hi All,

I just installed the ZHA-Map & ZHA Network Visualization Lovelcae Card and have been able to get a map of my Zigbee network using my HUSBZB-1.

I read that anything in red meant the LQI is below 128, My map looks like this

I also use the excellent ZHA Network card to monitor my Zigbee network but it reports I have a good strong network

I was wondering if anyone has tried this Zigbee network map and could share their results

2 Likes

Hi, I am new to this and found hard to follow the Github instructions. Could you kindly explain a bit more step to step to install these ZHA-Map & ZHA Network Visualization Lovelcae Card.
I am trying the installation the whole day.
Thank you in advance.

2 Likes

I’ve just finished setting up the ZHA network map and I’m getting pretty similar results my map looks just like yours and similar card results. I haven’t reset anything yet but I will keep you posted of my results, or further info.

I’m new to this as well and was getting confused by the step - Install the zha-network-visualization-card lovelace card.
I wasn’t sure where or how to install it, but after quite a few hours of research I found that you download the zipped file from the indicated github and then extract the folder and use your preferred method to transfer the zha-network-visualization-card.js to your home assistant config folder (I use Samba) and place the file in the/www folder (if the www folder doesn’t exist create a www folder). Inside the new www folder create a folder named zha-network-visualization-card and place the .js file of the same name in the folder.
it should look like this

config/www/zha-network-visualization-card/zha-network-visualization-card.js.

Once you’ve added the folders and the file go to your Lovelace overview page and open the Configure UI (top right corner) then press the button again and open Raw config Editor and add the following lines to the top of your file.

resources:

  • type: module
    url: /local/zha-network-visualization-card/zha-network-visualization-card.js

If you already have a resources: line don’t add another just add the lines below it to your existing resources: line.
Also you might have noticed that the url: above shows /local/ and not the /www/ that we created before. Home Assistant looks in your /www/ folder when you use /local/.

Once this is all done save your changes and leave the editor to confirm and load all of your changes check your config and reboot.
Once it back up you go to overview and open configure ui (top right corner) from here you can add a new view by clicking the + symbol next to home tab at the top left. This opens a View configuration window where you can name the new View but the only thing we are concerned with for now is the toggle at the bottom left that says panel mode. From there you can save and Home Assistant will create a new tab next to your home tab (Home Assistant call the screens Views). Open this new View which will be empty, at the bottom right click the + for cards window. Choose the manual card type and a card configuration window will open, this is where you will add

type: ‘custom:zha-network-visualization-card’

save and exit UI configurator, from here I restart Home Assistant and then once its back go to Developer Tools then open the Services tab and choose the zha_map.scan_now service and click call service button, you can check your logs for details and from there your new map card should show up for you.
As I mentioned in the beginning I’m new to this and I hope this helps.

4 Likes

1 Like

Sorry for my late reply on this. I got off the track.
That really helpful for me. Appreciate indeed your very details. I am making progress in using this HA and currently using HACS for this installation. I just got another issue with the ZHA output that showing most of my sensor’s battery at almost full percentage after more than one year. This is really weird. Also even with the very good quality RSSI/LQI , still i got offline state randomly at some times.Perhaps it’s was wifi/zigbee interfere. I am not ready to troubleshoot this at this stage.
Again thank you very much for your kind reply and wherever you are, stay safe from Covid19.

I still cannot get this to work. I’m on HA .108.3
I believe I have successfully installed zha_map as I have zha_map.scan_now as a callable service.
In Configuration->Lovelace Dashboards->Resources I have:
url: /local/zha-network-visualization-card/zha-network-visualization-card.js
as a javascript module

if I call my config dir (same dir where configuration.yaml resides) /config/
The path to the javascript is. /config/www/zha-network-visualization-card/zha-network-visualization-card.js

When I force the manual card to:
type: ‘custom:zha-network-visualization-card’
I get the error ‘Custom element doesn’t exist:zha-network-visualization-card’

I don’t need to have the Visual Studio Code add-on installed do I?

[Note, no longer relevant/required]

Dave,

I also struggled. I have recommended an update to the instructions as follows:

[snip]

  1. Install the zha-network-visualization-card lovelace card
  1. Add to your lovelace global config as type: module
  2. Add custom card (works best in panel mode): - type: ‘custom:zha-network-visualization-card’

[/snip]

[insert]

  1. Put the zha-network-visualization-card.js Lovelace card that you will find at GitHub - dmulcahey/zha-network-visualization-card: Lovelace custom element for visualizing the ZHA Zigbee network into the [config]/www/zha-network-vizualization-card directory ether by copying it there or by using the file editor to create it with a cut and paste of the content.

  2. Add the Lovelace Resource with Configuration¦Lovelace Dashboards¦Resources¦⊕¦URL:/local/zha-network-visualization-card.js & Resource Type JavaScript Module¦Update.

  3. Add custom card (works best in panel mode) through Overview¦ ⋮ ¦Configure UI¦ New Tab + ¦Give it a Title and any other options & select Panel Mode. Open this new View which will be empty, at the bottom right click the + for cards window. Choose the manual card type and a card configuration window will open, this is where you will add type: ‘custom:zha-network-visualization-card’. Save and exit UI configurator

  4. Optional: Restart Home Assistant. Once its back go to Developer Tools then open the Services tab and choose the zha_map.scan_now service and click call service button. Check logs for details

New map card should be there.

[/insert]

Credit due to JonG for his post above that put me on the right track. And to the makers of this. A key part of making ZigBee usable. I hadn’t realised how limited it is in range, and therefore how many router type devices are needed.

Hope this helps.
Andy

I’m on 108.6 and have done what you did. I have the scan service, made the resource and the manual map card still says unknown resource.

edit: I had to remove the quotes when adding the card.

Let me know how that goes. I’ve tried all the standard stuff. I put the .js file in the www folder itself and referenced it there. I made the entire www folder 777 permissions. Nothing seems to work. I just tried entering the card without the tick quotes and it still isn’t working here.

I have confirmed that zha-map runs. But I don’t think it matters since it says it simply cannot find the .js file… did you say you may know another method to force it? Maybe via configuration.yaml?

Lovelace resource handling (for custom cards) changed in 107 - most people now need to add the resources in configuration -> Lovelace Dashboards -> resources

@Richdem. I’m getting similar result like yours. In visualization card I got 2 red link, zooming in the graph show LQI 85 and 117, but on the ZHA Network card, the LQI column were all 255. which one should I believe ?

I’m using HUSBZB-1, HA v0.109.4, zha_map v0.11, visualization card (Jan27), zha-network-card (May04)

I deleted the ZHA Map,

It really caused my Home Assistant to slow to a crawl. I use only the zha-network-card and would suggest it is more accurate.

It would be nice to have the map function but I can live without it

1 Like

Hate to say it, but I had the same experience as Richard. zha-network-card works great. Muddled through zha-map install, and not only did the card act pretty flaky (I got circles for my devices, but no lines at all), but everything about my HA (docker) install started running like crap. Every section of the interface either didn’t load or would spin for a while before loading. Deleted the map component based on Richard’s comment and everything started running fine immediately.

I only have 4 devices moved over from Hubitat so far, so it wasn’t a network size issue or anything.

1 Like

i have the same, when the card is loaded, ha runs like crap, load spinning etc.

1 Like

Same issue here. After install a lot of errors on page loads from different pages. Uninstalled it all, and it works great again. Same small zigbee network as the post above. I’ve added the network card, no issues so far.

I’m very confused!

Does the ‘zha-network-card’ need ‘zha-map’ to display a zigbee mesh, or are they two independent and different addons for displaying maps?

Also, where’s ‘New Tab’ in ‘Configure UI’ and doesn’t the HACS Frontend Zha Network Card install the card?

Jim

I’m running a HUSBZB-1, 3x Ikea Tradfgri signal repeaters and a bunch of Xiaomi devices. Here is the error I get when I try to run the zha_map.scan_now service

2020-11-11 14:41:56 ERROR (MainThread) [homeassistant.components.websocket_api.http.connection.548128199920] 'EZSPCoordinator' object has no attribute 'neighbors'
Traceback (most recent call last):
  File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 125, in handle_call_service
    await hass.services.async_call(
  File "/usr/src/homeassistant/homeassistant/core.py", line 1308, in async_call
    task.result()
  File "/usr/src/homeassistant/homeassistant/core.py", line 1343, in _execute_service
    await handler.func(service_call)
  File "/config/custom_components/zha_map/__init__.py", line 66, in scan_now_handler
    await builder.preempt_build()
  File "/config/custom_components/zha_map/__init__.py", line 125, in preempt_build
    await self.build()
  File "/config/custom_components/zha_map/__init__.py", line 138, in build
    nei = await Neighbour.scan_device(device)
  File "/config/custom_components/zha_map/neighbour.py", line 78, in scan_device
    await r.scan()
  File "/config/custom_components/zha_map/neighbour.py", line 83, in scan
    for neighbor in self.device.neighbors:
AttributeError: 'EZSPCoordinator' object has no attribute 'neighbors'

Just in case someone on an older version finds this thread.
As of HA 2020-12.1 zha network visualization is built into the ZHA integration.

->Configuration/Integrations/zigbee/configure

Then select the visualization tab at the top of the page

6 Likes

Wow really,

That’s great. I’ll definitely take a look at this