ZHA not finishing the interview

My setup is HA up to date to latest version on a NUC. I have sonoff dongle E with ZHA. I have some Xiaomi Sensors, 2 blitzwolf plugs for repeat, symfonisk E1444 and to Zbmini-l2. My problem is that lately i have problems with pairing any device. I start having problems with one of the zbmini-l2, at the beggining it would report the state but i couldn’t control it. I tried to unpair it and pair it again but then it gets stuck at the interview configuration and if sometime go through I see it again go offline or reports just the state without control.

Any ideas? TIA

I did a Force Remove. Restarted HA and then repaired. It seemed to fix the problem.

Not working. Tried everything…

You could have a bad dongle, interference from wifi (remember your neighbors can stomp on your network too), a bad extension cable for dongle to your powered usb hub (you do have a powered usb hub and extension cable for your dongle right?) or even a jabbering Zigbee device that’s choking the network.

I assume you have tried moving your new device super close to your dongle to see if that improves things, so I would start trying to play with your wifi and/or Zigbee channels and see if it’s just an interference issue.

Most of the time I was without extension cable and it was working fine. I added, non powered, extension cable but I have tried to use it again without it. All in all, the problems started without chaning anything in my set up or the position from the devices. I have now moved the server far from the rourter though.

I will try another extension cable with extra power but there are 2 things that happening which looks weird to me.

  1. some devices such as aqara motion sensor or blitzwolf connects pretty easily.
  2. the zbmini l2 (2 of them) and the symfonisk e1444 doesn't even show the type of the dive as used to during the interview.
1 Like

Just for any one like me. Changed WiFi channel didn’t work. Changed ZIgbee Channel from 25 to 20, had to pair some devices again, but then everything it worked immediately

How do you change the ZigBee channel?

Assuming you are using ZHA Settings → Devices → Zigbee Home Automation and click the pencil next to Channel.