ZHA not working after migrating from RPi to Odroid

Please be gentle, I’m an old guy and a newbie having problems. I’ve migrated my home assistant from and RPi to an Odroid. The Odroid is the same spec as the Blue but with a generic case. Everything has gone well apart from the ZHA integration which uses a Conbee II stick. All of the Zigbee devices and entities are present but all show as being “unavailable”. In “Configuration” - “Integrations” - under the Conbee/ZHA sectio I have an error “Retrying setup: [Errno 2] could not open port /dev/serial/by-id/usb-dresden_elektronik_ingenieurtechnik_GmbH_ConBee_II_DE2258722-if00: [Errno 2] No such file or directory: '/dev/serial/by-id/usb-…”. I’m guessing that’s because I somehow need to tell the system which USB port to use???. But I have no idea how to point HA to the correct port. The Conbee II stick is connected using a USB extension cable and is some distance away from the Odroid. It’s the same stick and cable that works fine on the RPi.
Any help would be much appreciated (just remember that I’m an old guy and a newbie).

Hi Dexkingman,

You can use a console to find you conbee.

cd /dev/serial/by-id

You can also list the usb devices with


Best regards

I got the same problem. I found the solution in here and it worked, at least, for me

[SOLVED] ConBee II not recognized on HA Blue (Odroid N2+) - Configuration / Zigbee - Home Assistant Community (home-assistant.io)

You simply need to add an USB extension cable and it woks :slight_smile:

I saw that but unfortunately I’m already using an extension.

I’ve more or less fixed it now. I had to delete the integration and start again. The Conbee II retained the pairing so all the devices showed up. But all the entity IDs that I had changed reverted to their default values and all the area information was lost. So I had a fun time identifying each device and setting it’s area. Then going through all the entities which showed as “entity not available” in Lovelace and changing the names back to what I had before. Fortunately I only had 9 devices and 15 entities.

By chance are you running unRAID for your OS and then running home assistant within a virtual machine?

If so I’m having the same issues as you and I’ve done your exact steps unfortunately the problems return to me multiple times.

Sometimes I’ll be able to restart it and it’ll just find the path correctly, most times it won’t even find it.

What I will say is if you found it working now do not restart your home assistant if it all possible when I’ve got it working as soon as I restart HA it bombs.