ZHA OTA Update not working anymore!

I am trying to update my Tuya Zigbee Smart Plug using the below link:

I am on the latest HA version - Home Assistant 2022.12.9 and using SkyConnect Zigbee dongle.

I am manually trying to trigger an update and it’s just nor working. See the below screen. (note that I have redacted my entry for ieee just for posting here)

I m getting an error as in the second screenshot !

Hey man, since you already specified the servive in the dropdown you don’t need to add it to the yaml code. If you go to YAML mode you will see that the service property is duplicated.

Thank you fror the very quick reply. I will try it out now and let you know

its not duplicated in YAML mode. tried it in both UI & YAML Mode. still getting the same error. Its failing to call zha.issue_zigbee_command

I just tested and it’s working. You may have forgotten one of the steps. You may need to restart HA also. Check the logs to get more information.

Nope Still struggling.

  1. Modified my config file as below:

  1. did run the below on terminal

cd /config/zigpy_ota
wget https://images.tuyaeu.com/smart/firmware/upgrade/20220907/1662545193-oem_zg_tl8258_plug_OTA_3.0.0.bin

  1. Restarted HA and checked the logs. My log is empty when i use the egrep parameters as below:

  1. Tail of home-assistant.log shows the below:

  1. I am again manually trying to trigger an update and it’s just not working. It gives the same error:
    Failed to call service zha.issue_zigbee_command. Unknown error.

What home assistant version you are on ?

Hi @victorigualada , I just found from the logs that
" cluster 25 not found on endpoint 1 while issuing command 0 with args [0, 100] " .

When i go to plug’s signature in Manage Zigbee Device, i see the below signature:
(Also the device is from a different manufacturer - https://www.amazon.co.uk/gp/product/B09N43BBC1/ref=ppx_yo_dt_b_asin_title_o00_s01?ie=UTF8&th=1 but based on Tuya TS011F.

below ia the complete node descriptor:
“node_descriptor”: “NodeDescriptor(logical_type=<LogicalType.Router: 1>, complex_descriptor_available=0, user_descriptor_available=0, reserved=0, aps_flags=0, frequency_band=<FrequencyBand.Freq2400MHz: 8>, mac_capability_flags=<MACCapabilityFlags.AllocateAddress|RxOnWhenIdle|MainsPowered|FullFunctionDevice: 142>, manufacturer_code=4660, maximum_buffer_size=108, maximum_incoming_transfer_size=0, server_mask=11264, maximum_outgoing_transfer_size=0, descriptor_capability_field=<DescriptorCapability.NONE: 0>, *allocate_address=True, *is_alternate_pan_coordinator=False, *is_coordinator=False, *is_end_device=False, *is_full_function_device=True, *is_mains_powered=True, *is_receiver_on_when_idle=True, *is_router=True, *is_security_capable=False)”,

I’m not an expert at all in zigpy and ZHA so I can’t help you any further in this path.

What I would recommend is installing zigbee2mqtt to upgrade the device. It’s easier, only using the UI.
You won’t loose any of our current network devices created with ZHA. Give it a try. It’s the way I do it whenever I buy a new device now:

  1. Disable the ZHA integration
  2. Start Z2M
  3. Pair the device with Z2M
  4. Check if there are any updates and install them
  5. Stop Z2M
  6. Enable back ZHA
  7. Pair the device to ZHA

Pretty easy, more reliable and less PAIN.

Thank you. Will surely try that and let you know if it works !!!

You can try the ota_notify service from zha-toolkit - if the firmware is declared in Koenkk’s list, and you enable download, it will also download the binary for you.
Further it refreshes the ZHA firmware list, avoiding restart.

You do need to restart HA once to setup zha-toolkit (after modifying configuration.yaml), and I recommend that you enable the debug level before you start ota_notify so that you get some extra information in the log file (

service: logger.set_level
    custom_components.zha_toolkit: debug
1 Like

Tried this… disabled ZHA, installed Z2M addon.
I was able to start Zigbee2MQTT (using skyconnect as zigbee dongle)
Paired the device
Checked for updates. Seemed like there were no updates as per below screenshot:

Well no point if i cant use them , will go ahead and return them back !

Apparently the OTA cluster is not present.
There is one final thing that you can try: the Tuya magic spell. It unleaches functionnality on several Tuya devices - it might make things work for you - I am not sure that the OTA cluster suddenly appears.

Thank you, it sounds like a Very good recommendation. May be worth the try some other time as I have returned these and even got the refund ! I am planning to buy Samsung GP-WOU019BBDWG SmartThings Smart Plug 2019, https://amzn.eu/d/7oN5WWX

Perhaps they can work with ZHA along with power monitoring