ZHA - Philips Hue motion sensor

Hello,

I’m new to ZHA.

I’ve paired 2 Philips motion sensors (1 outdoor and 1 indoor) and some lights to ZHA by using a conbee II usb.
Before it was paired to a Hue bridge, so reset it and paring went well in ZHA.
I see values for the temperature, occupancy, illuminance, power.

But the on_off binary sensor detect never motion, although the occupancy sensor working correctly.

Am I missing something?
Do I need to configure something more?

Thanks!

1 Like

No one?

I’ve now based my automatons on the occupancy sensor, but there are some edge-cases where it doesn’t work very well.

Motion is still always on ‘off’.
How can I get the motion binary sensor working?

Thanks,
Erik

Hi,
I do not have any Hue Motion sensors but I found this online —

(I use Wyze and Aqara Motion Sensors)

Hey Erik, I’m seeing the same behavior. Also with a Conbee II, but don’t have any other advice right now.

Couldn’t you just change the device class to motion under Configuration --> Customizations?

I plan to move my outdoor sensor from my hue hub to my Conbee2 sometime soon. I’ll report back once I do.

1 Like

I have the same setup, with the exception that I use the HUSBZB-1 (Nortek) Zigbee stick, and I see the same thing as you. the Binary sensor doesn’t do anything or change states, but the occupancy sensor does. I have simply disabled the [worthless] binary sensor, and used the occupancy sensor for my automation in node-RED, and moved on. It works flawlessly this way. Just thought you might want to know, its not just you :blush:

1 Like

Hi did anyone get to the bottom of what the ‘on_off’ entity does, or not? I just bought one of these sensors and whilst the ‘occupancy’ entity seems to work OK, the on-off appears to do nothing.
The temperature and illuminance work OK too but I haven’t checked the accuracy yet.
I have latest version of the Hue add on / integration and HA is up to date.
I am using a Zigbee USB device and ZHA.
Any insight would be greatly appreciated.

I set the occupancy to be a motion sensor and disabled the ‘on_off’ one but I have another issue:

In HomeKit the sensors show as unavailable if they aren’t currently detecting motion (I guess when they’re sleeping because nothing is happening)…. Is there anyway I can change this by customising the entities to just show as clear when in this state?

I’d like to avoid making more entities via templates but if this is my only option: what do I need to include to ensure that they don’t just do the same thing?

My first Hue motion sensor has just arrived in the post today and I was keen to get it up and running on my Zigbee network. I’m using ZHA with a Sonoff ZBBridge flashed with Tasmota 10.1.0.
I am seeing exactly the same in ZHA - my motion sensor added successfully, however the on_off entity never changes from ‘clear’ and only the occupancy entity changes.

I thought perhaps the sensor needs a firmware update, however as I don’t have a Philips Hue bridge, I cannot update the firmware on it. Luckily my Hue bulbs and power outlets have Bluetooth so I have them in the Philips Hue app on my phone, and can update the firmware on them fine, however the motion sensor does not have Bluetooth so I cannot add it to the app.

Same here, I received yesterday my first hue outdoor motion sensor and easily integrated it in my zha network using conbee II but on_off sensor is no working :frowning:

This is not related to firmware. I’ve connected my Hue sensors to a Hue bridge and updated all sensors to the latest firmware, but the problem persists when I connect those back to ZHA.
I’ve tried deConz and it works fine, just like when integrating the sensor thru the Hue integration. In those cases, there’s no entity called “Occupancy”. You will see one entity called “Motion” which works fine.
Only on ZHA this behaviour with the on_off and occupancy entities.

The on_off entity is not a motion sensor.

See: ZHA: Philips Motion Sensor SML001 entities question

Out of curiosity I connected a spare Hue motion sensor to ZHA via my Sonoff Zigbee dongle and see the following entities -

  • Motion Sensor Occupancy
  • Motion Sensor illuminance
  • Motion Sensor Battery
  • Motion Sensor temperature
  • Motion Sensor on_off

Occupancy is the motion detection
Sensor On_Off disables motion detection

I have the same setup - Hue motion sensor and Sonoff Zigbee dongle. But on my sensor, the on_off entity is the motion sensor and seems update immediately.

The occupancy sensor never changes, and the illuminance and battery values are stuck at whatever level they were at when the Hue device was first added to the Zigbee network (a problem I’m still trying to solve).

FWIW - After several days of struggling to get my Phillips Hue Sensor working properly with a Sonoff Zigbee 3.0 dongle under ZHA, I switched to giving Zigbee2mqtt a try - and it works beautifully. All entites seem to be updating, and occupancy is reported by the “occupancy” entity (there is no “on_off” in the discovered configuration).

The discovered entities are:

  • illumination
  • occupancy
  • temperature
  • battery
  • update available
  • occupancy timeout (settable)
  • motion sensitivity (settable)

I’m new to HA and have no previous experience with Zigbee, so I have no idea of how ZHA configures the sensor compared to Zigbee2mqtt during the new device interview process, or how I might have altered any yaml for ZHA to get the sensor working. So although ZHA was much easier to configure initially compared to mosquitto/Zigbee2mqtt, I couldn’t figure out how to have the sensor work properly with ZHA.

[edit] Add the fact that I’m running HAOS in a VM on Windows 10.

1 Like