ZHA + Phillips Hue Motion

I’ve just installed a Hue Motion Sensor SML002 into ZHA and it joined without problems and I see it has created an Binary Sensor for OnOff, Occupancy and sensors for Luminosity, Temperature and battery.

It seems to trigger very frequently about every minute to two minutes even though there is no place to reflect off. I cant see where to change this in the ZHA control panel

I have the Cluster- OccupancySensing (Endpoint id:2, ID: 0x0406, type: in) which has the attributes

{id: 0, name: "occupancy"}

{id: 1, name: "occupancy_sensor_type"}

{id: 16, name: "pir_o_to_u_delay"}

{id: 17, name: "pir_u_to_o_delay"}

{id: 18, name: "pir_u_to_o_threshold"}

{id: 32, name: "ultrasonic_o_to_u_delay"}

{id: 33, name: "ultrasonic_u_to_o_delay"}

{id: 34, name: "ultrasonic_u_to_o_threshold"}

I’ve tried setting u_to_o threshold to ‘0’ and ultrasonic u_to_o threshold also to ‘0’, but this doesnt seem to have made a difference. Anyone actually managed to change this like can be done in hue app?

how are you setting the sensitivity ?
I though it was fixed at 2 (factory) where 0=low 2=high
Have you tried REST/API to set it?

I’ve tried it in the ZHA config panel

Config -> ZHA -> Device
-> Clusters -> OccupancySensing
-> Cluster Attributes -> ultrasonic_u_to_o_threshold

When i try to ‘get zigbee attribute’, I get ‘None’ in the value field after about a minute. When setting this to 0 and pressing ‘set zigbee attribute’, i get the ‘set zigbee attribute’ go green after it spins, however it doesnt seem to make a difference and it activates every few minutes

Add a debug log and post back contents of homeassistant.log

Configuration.yaml:

logger:
  default: warning
  logs:
    homeassistant.components.zha: debug

Sorry for posting to an old topic however wondering if you ever got this working? I’m also trying to reduce the sensitivity of the hue motion sensor.

I connected mine to a Philips hue hub, updated the software and changed the sensitivity and then reconnected to ZHA

As a new to Hass.io on Raspi, mind if I ask @confusedshrubbery which Zigbee dongle do you use? I’ve got Texas_Instruments_TI_CC2531 based USB-dongle and I seem to not be able to get Hue Motion Sensor SML002 to be used at all in ZHA. No triggering or readouts from temps etc.